Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Unable to upload Oculus Go app: "Certificate Changed"

Evans_Taylor_DigitalEvans_Taylor_Digital Posts: 16 Oculus Start Member
Hi there,

I'm having a weird issue with the Oculus store. I am trying to upload an apk to an alpha release channel file on a newly created app. I am being given the following error message:



The thing is: this is the first time the apk is being uploaded to the store and there is no previous version... which is weird. I've even tried deleting the app in the dashboard and re-creating again and then uploading the apk again but I get the same error. I've also tried creating a new signing certificate and uploading that one instead but again I get the same error.

The app is created with Unity, and the signing process is as described in the documentation. I've never come across this issue with other apps I have distributed via the Oculus store.

Anyone have a clue how to fix this??

Comments

  • Evans_Taylor_DigitalEvans_Taylor_Digital Posts: 16 Oculus Start Member
    I managed to solve this issue. It was either because I had not added a bundle identifier or I was using the wrong oculus app id
  • ProVirtualMenteProVirtualMente Posts: 3
    NerveGear
    edited August 2019
    Hey Evans! I have the same inssue but i dont know what i need to take for identifier or where i need to put it. Can you detail me the process please?

    Thx!
  • ProVirtualMenteProVirtualMente Posts: 3
    NerveGear
    Fixe it!. I was change the same name of name proyect, " AndroidPackageName" and "Distribution Singning" (meaby work change only in last one but i dont know)

    EX:
    KeyStore: test.keystore
    KeyAlias: test

    Good luck!
Sign In or Register to comment.