UE4 Editor crashes when trying to launch build on the Quest — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

UE4 Editor crashes when trying to launch build on the Quest

weirdmonkey2807weirdmonkey2807 Posts: 9
NerveGear
edited June 5 in Unreal Development
Hi guys,

I am running UE4 4.22.2 (oculus partner edition) - built from source. 

I've been successfully building my project and launching it on the Quest for a few weeks but today after making some changes (minor lighting adjustments) I tried to build again and all I got was a Fatal error and it won't launch to the Quest anymore. I have had this same issue (also built from source) on another machine where I could never get it to launch either. 

Any pointers on what could have happened?

Comments

  • SlayeminSlayemin Posts: 36 Oculus Start Member
    Are you able to look at the call stack? Do you get any error logs to look at? Can you reproduce the problem consistently? Does the problem happen on a new, empty project? If you're using source control, does going back to a last known good build resolve the issue?
  • weirdmonkey2807weirdmonkey2807 Posts: 9
    NerveGear
    @Slayemin

    thanks for your reply. Actually no errors I can make out in the crash logs that were created in the project folder.

    I did some more testing and found the project builds just fine when I don't use the Launch directly to the Quest. 

    When I use File, Package Project, Android ASTC it builds the project successfully and without any errors. I can then run the Install.bat and run the project on the Quest.

    Btw this also happens on the sample projects when I start from scratch. 
  • hcentenohcenteno Posts: 16
    NerveGear
    edited June 8
    I have the same exact problem but I haven't been able to directly launch to device even once. It always crashes with Fatal Error and no back traces or errors in the log. I'm only able to deploy by packaging and then sideloading the APK with ADB.
  • weirdmonkey2807weirdmonkey2807 Posts: 9
    NerveGear
    It used to work for me up until around June 7th. Did @OculusSupport push an update that caused this issue?
Sign In or Register to comment.