Is there a way to disable asymmetric FOV? — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Is there a way to disable asymmetric FOV?

needleoculusneedleoculus Posts: 86
Hiro Protagonist
edited June 9 in Unity Development
As seen here and here, various stereo shader effects break in Unity versions that has asymmetric FOV rendering enabled (2017.4.11f1 and above). Neither of the aforementioned threads ended with the problems being fixed. While fixing those shaders to adapt to asymmetric FOV is one solution, going around fixing every single one of them can be costly. Is there a way to disable asymmetric FOV rendering? Poking around in OVRPlugin.cs, it seems that only querying the current state is exposed. Is there some method to manually disable asymmetric FOV to make the shaders work again for the time being, or is going back to older versions of Unity the only way out? The latter method doesn't seem likely now that 2017.4.11f1 has been declared the minimum supported version.
Sign In or Register to comment.