Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

MSAA Anti-Aliasing Quality in Oculus Quest with Unreal Engine

I'm developing an application for Oculus Quest using Unreal Engine 4.22, everything is fine except the Anti-Aliasing which looks bad. Edges in high contrast keeps flickering and it's very distracting to the eyes. 

Using the default VR template for testing, I tried turning MSAA ON (2x, 4x, and 8x) and OFF, and there's never any differences. I also tried a few console commands (in config files and device profil) like r.MobileContentScaleFactor, vr.PixelDensity, r.MobileMSAA, r.MobileOnChipMSAA, r.PostProcessAAQuality, and still nothing... Also, when I turn Mobile HDR on, the app just don't open inside Oculus Quest. I know there's a few posts on this online already, but I could not find any solution, except using Unity instead. 

This documentation seem to imply that MSAA is configurable:
https://developer.oculus.com/documentation/quest/latest/concepts/quest-msaa/

The guy here also says that it's possible:
https://www.youtube.com/watch?v=hEtu-ciPc7g


Is there anyone who succeeded to change the Anti-Aliasing quality with Oculus Quest or Go in Unreal Engine 4.22? If yes, how exactly?
Is Mobile HDR supposed to work with Oculus Quest? If so, I would be interested in knowing how to make it work as well.
Is it possible to render at a higher resolution?

Thank you!

Comments

  • weirdmonkey2807weirdmonkey2807 Posts: 16
    NerveGear
    The guy here also says that it's possible:
    https://www.youtube.com/watch?v=hEtu-ciPc7g

    he is referring to FFR which stands for Fixed Foveated Rendering and basically improves performance by only rendering pixels towards the center of your view. 

    @francis.lavergne
    I also have the same issue with Aliasing in my build from Unreal Engine when running on the Quest. Like you said turning on 4x MSAA for example makes 0 difference to my visuals.


  • PixoGroupPixoGroup Posts: 4
    NerveGear
    Most likely need to switch to forward rendering if you want MSAA.
  • francis.lavergnefrancis.lavergne Posts: 2
    NerveGear
    PixoGroup said:
    Most likely need to switch to forward rendering if you want MSAA.
    I turned ON Forward rendering and MSAA in my projet settings and it did not do any difference. In fact, I think Forward is always active on Quest/Go even if unchecked. The forward option seems to only makes a difference on Rift. 

    he is referring to FFR which stands for Fixed Foveated Rendering and basically improves performance by only rendering pixels towards the center of your view. 
    You're right! Sorry my mistake. 
  • demonixisdemonixis Posts: 2
    NerveGear
    Hello, 

    Same problem here, no MSAA with UE4.22 and no mobile HDR. I'm reporting the issue.
  • weirdmonkey2807weirdmonkey2807 Posts: 16
    NerveGear
    @demonixis awesome. do you have a link to your bug report. did you file it here: https://developer.oculus.com/bugs/ ?
  • Barzum_01Barzum_01 Posts: 7
    NerveGear
    Its not a bug, its hardcoded to 4x MSAA

  • vikneshtkvikneshtk Posts: 12
    NerveGear
    @demonixis  For mobile devices, Oculus hard coded the MSAA value to 4x. Seems like this has been done purposefully  to address the performance issues related to it.
  • rasamayarasamaya Posts: 13
    NerveGear
    Your project runs with mobile hdr on in quest? Please tell me your secrets!!!!
  • evrtop888evrtop888 Posts: 4
    NerveGear
    How is the problem solved?
  • FeroxDFeroxD Posts: 32
    Brain Burst
    The same i got that polygon spikes and i don't know how to fix thats..
  • remozremoz Posts: 69
    Hiro Protagonist
    very interesting. I am running into the same issues when it comes to AA. I am getting black artifacts.
    see screenshot below:


    No matter if I change the MSAA 2x, 4x, 8x

    It's a super simple setup, just with primitive objects and I can't figure out why it's doing it.

    VIDEO EXPLANATION:
    https://youtu.be/U1sdR8S73P4

    Updated Scene File:
    In my latest Project File, I added a rotating head-sculpture. I wanted to see the performance when an object is rotating. As expected, frames drop. For the rotation I am losing about -20 FPS. 

    DOWNLOAD PROJECT FILE Unreal 4.24.2:
    https://mega.nz/#!gWJREKYI!XIlBMFzjC9OKbHffLKr8aKF6kZ6MdFQJBhPN-RzzBE8

    My Documentation about Debugging and my Developing-Process for the Quest can be found here:
    https://fattybull.com/oculus-quest/

    Sorry for my current mess.. I am planing to structure the post this weekend, so people can actually follow step by step.

    Another issue I am currently experiencing:
    - the geometry seems to "jump" or it's kinda "jittery"

    and I can't figure out what's causing it, even if I am just using a plane and one cube.

    Curious about your thoughts & ideas.
    Thank you so much for any little hint, I really do appreciate that.

    happy pixeling,
    cheers
  • remozremoz Posts: 69
    Hiro Protagonist
    I was running additional tests.. but that problem seems to be consistent, no solution yet to fix it. Is this just a major bug?
Sign In or Register to comment.