Error when Packaging in UE4 4.22.2 — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Error when Packaging in UE4 4.22.2

mcoluzzimcoluzzi Posts: 1
NerveGear
I am struggling to try to get a basic package to deploy with my new Quest. I am new to mobile VR development and was trying to start deploying just using the TouchSample project provided in the Oculus UE4 Source Branch. Below is my error I am running into.

LogPlayLevel: ====6/12/2019 10:49:02 PM====PERFORMING FINAL APK PACKAGE OPERATION================================================
LogPlayLevel: Fixing minSdkVersion; NDK level above 19 requires minSdkVersion of 21 (arch=armv7)
LogPlayLevel: Fix gradlew permissions
LogPlayLevel: Making .apk with Gradle...
LogPlayLevel: FAILURE: Build failed with an exception.
LogPlayLevel: * What went wrong:
LogPlayLevel: Could not determine java version from '11.0.1'.
LogPlayLevel: * Try:
LogPlayLevel: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
LogPlayLevel: * Get more help at https://help.gradle.org
LogPlayLevel: Error: ERROR: /bin/sh failed with args -c '"/Users/username/Desktop/UnrealEngine-4.22/Samples/Oculus/TouchSample/Intermediate/Android/APK/gradle/gradlew" :app:assembleDebug'
LogPlayLevel:        (see /Users/username/Library/Logs/Unreal Engine/LocalBuildLogs/Log.txt for full exception trace)
LogPlayLevel: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 11.209150
LogPlayLevel: Error: RunUAT ERROR: AutomationTool was unable to run successfully.
PackagingResults: Error: Launch failed! Unknown Error
Sign In or Register to comment.