can not use VRTK — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

can not use VRTK

1364887753113648877531 Posts: 2
NerveGear
Exception: An SDK Setup from the provided list could be loaded, but the device is not in working order. There are no other Setups in the provided list to try.
VRTK.VRTK_Logger.Log (VRTK.VRTK_Logger+LogLevels level, System.String message, System.Boolean forcePause) (at Assets/VRTK/Source/Scripts/Internal/VRTK_Logger.cs:174)
VRTK.VRTK_Logger.Error (System.String message, System.Boolean forcePause) (at Assets/VRTK/Source/Scripts/Internal/VRTK_Logger.cs:130)
VRTK.VRTK_SDKManager+<FinishSDKSetupLoading>d__96.MoveNext () (at Assets/VRTK/Source/Scripts/Utilities/SDK/VRTK_SDKManager.cs:943)
UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at C:/buildslave/unity/build/Runtime/Export/Coroutines.cs:17)

When I check virtual reality support box,and choose  oculus,it will work like the first picture,and then,it like the second picture:

I don‘t konw why,oculus just can't be choosen.

Comments

  • Geist2501Geist2501 Posts: 21
    Brain Burst
    edited July 8
    Since you did not say anything about whether or not you have installed the Oculus Integration from the asset store and SDK packages in the Package Manager, i would ask you to make sure you have done so.

    edit: Also make sure you run one of the recommended versions of unity. Check the FAQ. And unless you definitely need features from unity 2019, consider using a earlier version that does not force gradle building. You can always port up later, but gradle takes ages to build each time you want to test something.
Sign In or Register to comment.