App keeps launching in a window on the Oculus Go — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

App keeps launching in a window on the Oculus Go

AIEMelbAIEMelb Posts: 3
NerveGear
Hi all,
I'm making a game for Oculus Go using Unity and everything has been working fine all week, then suddenly it started behaving very strangely.
When I go Build and Run in Unity, it appears to build successfully, there are no error messages and unity says Build Successful.
Then in the Oculus Go, the game appears as a non-interactive window in the place of the normal Home screen, as a floating curved window.
The OS is still visible in the background and the OS menu is still visible below. The game is updating (things are moving) but I can't interact with it.

I have no idea why it suddenly started doing this, everything was fine one moment then not the next. I don't recall changing any scripts in between, I definitely didn't change any player settings.

I didn't even think lanching an app in a window like this was possible.
Does anyone know what might be causing it and how I can get it to go back to being full screen?

I have tried rebooting the Oculus Go and Unity.

Comments

  • Geist2501Geist2501 Posts: 21
    Brain Burst
    I had a very similar problem in my first steps with the quest.
    You can read about my problem here if you like:

    Generally i think it came down to the Unity version i was using. Right now i work in 2017.4 as it builds way faster and does provide everything unity has to offer that does actually work on android. But i tested with 2018 and 2019 - the versions recommended in the Documentation.

    I plan to port my game up to the last versions once i have passed beta stage.
    What version are you using?
  • AIEMelbAIEMelb Posts: 3
    NerveGear
    I'm using 2018 and it was working fine and I didn't upgrade unity. The only thing I did between working and not working was add a particle effect to my scene and close SteamVR. Even though it's not a Vive game and its running on the Go I'm wondering if SteamVR somehow messed it up. I have tried reopening it but it didn't fix the issue.
  • AIEMelbAIEMelb Posts: 3
    NerveGear
    I fixed this by just going through all the settings in the Oculus menu and toggling a whole bunch of things off and on again. Seems to have been a bug.
Sign In or Register to comment.