Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

[Unity/Rift S] Unchecking "Use Position Tracking" in OVR Manager leads to weird distortions in HMD

astaudeastaude Posts: 1
NerveGear
Using:
- Unity 2018.4.2
- Oculus Integration 1.38
- Rift S

Test Environment:
- Clean, new project, only Oculus Integration inside and a test scene with default cubes
- Tested on two different machines with two different Rift S headsets

Problem:
When I disable "Use Position Tracking" in the OVRManager of the default OVRCameraRig, the image inside the HMD gets super distorted. The image in editor is displayed correctly however. What I would expect from this checkbox is to simply disable 6-DoF positonal tracking and switch to 3-DoF instead. So there seems to be a bug of some kind.

Does anyone know about this one or can provide a workaround for dynamically switching between 6- and 3-DoF on runtime?

Best,
Adrian

Comments

  • TANStudioTANStudio Posts: 3 Oculus Start Member
    Same Same Same
    Just by unchecking the Use Position Tracking local distortion smudges appears.
    and no idea what to do.
    Please share solution if you found any.
  • EledwinEledwin Posts: 1
    NerveGear
    Hey,

    Just found a solution. If you uncheck the "Use Positional Tracking" checkbox you have to set the Tracking Origin Type to Eye Level. Otherwise you get those distorted rendering. This is because Floor Level as Tracking Origin Type is assuming a 6 DOF tracking, which is incompatible with a disable positional tracking...
    Hope it help.
Sign In or Register to comment.