IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

problem with unity build and Quest

Hello, 
I was trying to test how to import a unity build on oculus quest and i encountered an infinite loading screen problem.

-activate developer mode in my oculus quest settings
-make a simple scene with a camera, light and a cube to observe in unity 2019.1.6f1.
-import oculus integration package on the asset store
-in build setting, select android, switch platform and add open scene to the scene in build
-in player setting > other setting select Android4.4 'KitKat'
-in player setting > XR setting, activate virtual reality supported and select oculus
-in oculus > platform > edit setting, i added the application id of my app

and then when i hit the build and run button, unity answer me with a build succesful message but the oculus quest is stuck in a black screen with the loading white dots.
I tested different fix found around internet (like delete vulkan API) but none of them seems to work, if someone has an idea of how to solve this problem i would be very grateful.
thanks

Comments

  • larsonmattrlarsonmattr Posts: 7
    NerveGear
    Things I have hit / ideas:
    1) Try setting the minSDK as Android Marshmellow API 23
    2) Check that you are using the Oculus(Android) package not the Oculus(Desktop) package.
    3) After setting the platform to Android, sometimes this has undone setting the Player Settings->XR enabled, so double-check that this is still set correctly.
    4) As mentioned, use OpenGL ES 3.0, not Vulcan.

  • EmbarcaderoEmbarcadero Posts: 1
    NerveGear
    For anyone still wondering (like me after 8 hours).
    What fixed the problem for me was downloading and importing the new Oculus Utilities for unity.
Sign In or Register to comment.