Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

localavatar hands not appearing in new oculus integration update

bullseye179bullseye179 Posts: 2
NerveGear
As of Oculus Integration 1.39 released today (7/26/2019) on the unity asset store, unity no longer renders the an Oculus Quest's player hands when using the default OVRPlayerController plus LocalAvatar combination. There doesn't seem to be an easy way to fix. Any suggestions?

Comments

  • darren_hotlavadarren_hotlava Posts: 6
    NerveGear
    Just got the new 7.0 Update today and can verify that this does not work for me as well. I have built a fresh Unity project with Unity 2019.1.6f1, installed the new Oculus Integration 1.39 that was released today (7/26/2019), and built the startup scene for Oculus Quest. Result is no hands. I also did not have hands prior to updating while running 1.38.

    Is this a problem in the 7.0 update or the Integration?

    Also, why does the "new" spatializer force 2d when running in the Editor? This worked fine with 1.37 and the older spatializer.
  • bullseye179bullseye179 Posts: 2
    NerveGear
    I found the solution from other posts in this topic. I just didn't look hard enough. Just make sure to do:
    Oculus/Tools/Create store-compatible AndroidManifest.xml
  • darren_hotlavadarren_hotlava Posts: 6
    NerveGear
    edited July 26
    <?xml version="1.0" encoding="utf-8" standalone="no"?>
    <manifest xmlns:android="http://schemas.android.com/apk/res/android"
        android:installLocation="auto">
        <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" /><!-- Request the headset DoF mode -->
        <application
            android:allowBackup="false">
            <activity
                android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen"
                android:configChanges="locale|fontScale|keyboard|keyboardHidden|mcc|mnc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|touchscreen|uiMode"
                android:launchMode="singleTask"
                android:name="com.unity3d.player.UnityPlayerActivity"
                android:excludeFromRecents="true">
                <intent-filter>
                    <action android:name="android.intent.action.MAIN"/>
                    <category android:name="android.intent.category.INFO"/>
                </intent-filter>
            </activity>
            <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="false" />
        </application>
    </manifest>


    This is what is created. This still doesn't show my hands. More info: using single pass rendering.
  • mrdavletmrdavlet Posts: 5
    NerveGear
    have no hands too...) bump!
  • SilentAce07SilentAce07 Posts: 4
    NerveGear
    Make sure the manifest indicates:
       <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" />

    Or just have it auto generate one like above suggestion. 
  • darren_hotlavadarren_hotlava Posts: 6
    NerveGear
    I have reverted back to Oculus Integration 1.37. The manifest changes above allow me to run again and my hands are showing (I was crashing after the 7.0 update before when the hands were shown in 1.37.)

    I am no longer blocked, but I will not be updating to 1.39... ever.

  • rodrigo.ruizurrejolarodrigo.ruizurrejola Posts: 2
    NerveGear
    <?xml version="1.0" encoding="utf-8" standalone="no"?>
    <manifest xmlns:android="http://schemas.android.com/apk/res/android"
        android:installLocation="auto">
        <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" /><!-- Request the headset DoF mode -->
        <application
            android:allowBackup="false">
            <activity
                android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen"
                android:configChanges="locale|fontScale|keyboard|keyboardHidden|mcc|mnc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|touchscreen|uiMode"
                android:launchMode="singleTask"
                android:name="com.unity3d.player.UnityPlayerActivity"
                android:excludeFromRecents="true">
                <intent-filter>
                    <action android:name="android.intent.action.MAIN"/>
                    <category android:name="android.intent.category.INFO"/>
                </intent-filter>
            </activity>
            <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="false" />
        </application>
    </manifest>


    This is what is created. This still doesn't show my hands. More info: using single pass rendering.
    This won't wont, you have to change it to
     <category android:name="android.intent.category.LAUNCHER"/>
    i'm running fine again with integration 1.39.

    Also middle finger for you oculus for throwing this at us without any warning :P, i lost all day testing and solving this issue
  • blobfaceblobface Posts: 1
    NerveGear
    Any chance someone could post their working xml here? When I auto generate the xml, not only do I not see the hands / avatar, even the joystick movement is extremely buggy. However, by adding the line suggested above and replacing INFO to LAUNCHER, while I still do not see any hands, I could at least reliably glide around and turn with the joysticks, so it improved it, but still not fully working. Thanks!
  • chiltonchilton Posts: 11
    NerveGear
    For me, it was this easy:
    Remove androidmanifest.xml, then add a store compatible one. 
    That fixed all of these issues for me. 
  • darren_hotlavadarren_hotlava Posts: 6
    NerveGear
    I am geting the same result as blobface. The intent change to LAUNCHER does nothing to make either hand show up nor the controllers. I DO get the pointer beam that originates from the location of the hands, and the UI is working when I select it.

    Everything works fine on the Rift side as long as I delete the new spatializer.

  • BarbadelBarbadel Posts: 4
    NerveGear
    I am also getting the same results as blobface... Improved motion but still no hands or body. Any help would be highly appreciated.
  • hawkenhawken Posts: 19
    NerveGear
    edited July 31
    I've followed the advice for the manifest to get Quest controllers back but no luck getting avatar objects to show (hands, body). Is 1.37 the best solution right now?
  • BarbadelBarbadel Posts: 4
    NerveGear
    I've finally managed to get my hands to appear in my game but all credits goes to Valem on youtube.
    So this is his solution:
    "Since 25/07, the new version 1.39 of the Oculus Integration has changed how the Local Avatar works. Here is the fix : To see your avatar, you have to register an oculus app id. On the top panel go to Oculus / Avatars / Edit Settings, you can create an oculus app id here https://dashboard.oculus.com/ (useful if you want to make some multiplayer stuff or publish to oculus store) BUT any number as the Oculus App ID will also works !"

    So its that simple... enter an App ID, rebuild and your hands should now appear...
  • couplercoupler Posts: 4
    NerveGear
    that works for me as well, but does anyone else see their performance degrading (every frame it seems to get worse) to the point where it starts to run at 1fps? this is happening in AvatarGrab, but not the CustomHands demo scenes.
  • darren_hotlavadarren_hotlava Posts: 6
    NerveGear
    edited August 1
    I just started a new Unity Project in 2019.2.0f1, assigned the 1.38.1 Android and Desktop Oculus (Oculii?) Integrations from the package manager, then pulled down and installed the 1.39 Integration from the Asset Store. I enabled 1.39, deleted the new spatializer, loaded the Startup scene in the sample framework and setup the platform for Android. I regenerated the android manifest, and switched over the OvrCameraRig to use Quest. I disabled the locomotion controller.

    None of this showed my hands when I ran on Android. The hands showed fine on Rift.

    Then I went and created a test project in the portal to get an app id for Quest, set it up for both the Avatar settings and the Platform settings, then rebuilt for Android.

    Hands finally showed up... after a few seconds of them not showing up, where I presume the Integration is hitting the internet or loading something in the background.

    Bottom line is that Quest requires an App Id for avatar to work as an undocumented step.

    So this works for me now... at least in a test project. Now I have to see if I can get it working in my main project.

    Thanks Barbadel.
  • ArloreanArlorean Posts: 3
    NerveGear
    edited September 15
    coupler said:
    that works for me as well, but does anyone else see their performance degrading (every frame it seems to get worse) to the point where it starts to run at 1fps? this is happening in AvatarGrab, but not the CustomHands demo scenes.
    I get exactly the same problem. The hands only appear in AvatarGrab when I set Oculus->Avatars->Edit Settings->Oculus Go/Quest or Gear VR [?]  to something, any number it seems, even 12345:

    But then the frame rate continuously drops and it's unusable. This is in Unity 2019.2.4f1 (on Windows) with Oculus Integration 1.40.
    CustomHands seems to work with or without this Avatar App Id being set and the frame rate is great.
    GripPoses needs the Avatar App Id setting to 12345 as well for the hands to show but the performance seems OK, although the scene just has hands in it.
    Does anyone have any suggestions to fix this?
  • CorysiaCorysia Posts: 91
    Hiro Protagonist
    Have you tried a real AppID instead of your made-up one?
  • ArloreanArlorean Posts: 3
    NerveGear
    I tried a real AppID that I created on the Oculus Dashboard and it worked as well as a made up number but there were the same performance issues in the AvatarGrab sample unfortunately. Thanks for the suggestion though.
  • CorysiaCorysia Posts: 91
    Hiro Protagonist
    Darn!  I was hoping you were running in to some sort of authentication loop in the background that was killing performance.
  • CorysiaCorysia Posts: 91
    Hiro Protagonist
    I updated my Example to use 1.40 last night and I didn't find any performance hit.  But I didn't use Custom Hands -- I saw a huge hit with that.  I also got rid of the jitter when moving the held object.
  • ArloreanArlorean Posts: 3
    NerveGear
    The AvatarGrab sample problem was a missing Controller Shader from the LocalAvatarWithGrab prefab:

    This shader is set to OvrAvatar/AvatarSurfaceShaderPBSV2 in the LocalAvatar prefab so setting that on the LocalAvatarWithGrab prefab fixes the problem where the missing shader makes Unity regenerate part of the skinned mesh constantly which causes the slowdown and tracking problems:

    I'd be interested to see if you can get the LocalAvatarWithGrab sample to work in your example code now.
  • DurhamETechDurhamETech Posts: 1
    NerveGear
    edited September 23
    I am running into this issue, but not with Avatars. I'm using 2019.1.13f1 and have tried 1.38, 1.39 and 1.40 and in none of them do my Oculus controllers show up. It's pretty clear my controllers are tracking properly, since I have visible on pointer enter effects that give away where the controllers are pointing and they show up against the guardian boundary, but none of the GameObjects and Components attached to the HandAnchors are appearing. I have an updated manifest with <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" /> for the Oculus 1.38/1.39? changes to run Go apps on quest and I have added an app ID and neither of these solutions are working for me -- I am just using a controller mesh and a line renderer. I'm using LWRP, but I've upgraded all materials that I'm using to LWRP ones.  Any ideas on how to fix this?
  • AGTDigitalAGTDigital Posts: 14
    NerveGear
    edited September 25
    Hello,

    I got the issue too.
    As soon as you add the "LocalAvatar" prefab to the Unity scene, if you build and launch the application on your Quest and press any button on the controller, the app crash.

    Even the "LocalAvatar" sample scene provide by Oculus does not work. I have already tried to delete and recreate an AndroidManifest with the Oculus tool but nothing works...

    I use Unity 2017.4.31f1 and I got this issue with Oculus Integration v1.39 and v1.40 too.

    @NinjaGG ; Is there any solution for this ?
  • knowndeadknowndead Posts: 2
    NerveGear
    Running unity 2019.2.6f1 v1.40, i will see if it works for me tomorrow, it is really weird how bad the oculus integration is for how much they enforce even using it... i've literally been busy the entire week just trying to port stuff over from steamVR since we want a oculus quest version...
  • knowndeadknowndead Posts: 2
    NerveGear
    so it doesn't work for me either is the short story, couldn't get it fixed in a reasonable amount of time...
  • el_jergasel_jergas Posts: 15
    NerveGear
    I think almost everyone has reported these bugs; still waiting for them to fix it 😖
  • AGTDigitalAGTDigital Posts: 14
    NerveGear
    UP
  • VRisingVRising Posts: 31
    Brain Burst
    How do I report this bug?
  • AGTDigitalAGTDigital Posts: 14
    NerveGear
    I have more information on the problem of displaying hands.
    As mentioned above, as soon as one of the buttons on one of the controllers is pressed, the application crashes and you can't see the hands at any time.

    Indeed @Corysia , in your project we can see the hands, thank you for your investment by the way, except as you say in the description of your project, it's on Unity 2019.1.4f1.

    I reproduced exactly the same scene with the same components and values on Unity 2017.4.31f1, but the application still crashes.

    Version 1.41 of Oculus Integration does not fix anything about this, you can test the Oculus test scene "localAvatar" for example....


    I hope there will be a solution soon...
    Is there some news about it @NinjaGG ; ?

  • CorysiaCorysia Posts: 91
    Hiro Protagonist
    Indeed @Corysia , in your project we can see the hands, thank you for your investment by the way, except as you say in the description of your project, it's on Unity 2019.1.4f1.
    Yes, I didn't test it with older versions of Unity and I'm reluctant to spend the time on Alpha or Beta versions, too.

    It's only my opinion, but I doubt Oculus is going to go back and test in 2017 and probably not even 2018.  If they do, I'd only expect they would look at the LTS releases.  Yet, they clearly state that it's compatible with 2017.4.11 or higher.  Either they need to actually test it, or change what they say it's compatible with.
Sign In or Register to comment.