IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

hands not showing up with LocalAvator Unity

Blitz64Blitz64 Posts: 8
NerveGear
I'm using LocalAvatar -> AvatarGrabberLeft
Oculus Quest
Unity 2019.1.12f1
Oculus Integration 1.39

I can grab objects but my hands are like invisible.   I'm new to unity Oculus Quest development.   I created a brand new project with just 1 cube so I can grab it.

Initially I can't even grab the objects.  I did Tools -> Remove AndroidManifest.xml and then create Store compatible AndroidManifest.xml.

I tried the AvatarGrab Scene that has built in Oculus cubes and I still can't see my own 2 hands.   I can still grab stuff pretending I have an invisible hand.   Anyone know a fix?


Comments

  • AdrellaDevAdrellaDev Posts: 2
    NerveGear
    It's a different issue from the Android thing. There seems to be a bug in Oculus Intergration 1.39 that causes the hand mesh to disappear. I reverted back to 1.38 and it was fixed.
  • Blitz64Blitz64 Posts: 8
    NerveGear
    Thanks. 1.38 worked and showed my hands.
  • GuwopdeLaJeanGuwopdeLaJean Posts: 2
    NerveGear
    edited August 3
    Blitz64 said:
    1.39 works as well.  I need to enter my App ID from dashboard.oculus.com in Oculus -> Avatar
    This worked for me!  Thanks I have been going crazy trying to find a fix. Care to explain how you figured it out?
  • alessio.grancinialessio.grancini Posts: 2
    NerveGear
    edited August 12
    Hello everyone, after three days working on this I thought to share the sample scene working correctly here. 
    What a pain. Insert your app ID and should be working smoothly. 
    [In both Platform settings and Avatar settings]

    Cheers ! 
  • PFH-GoettingenPFH-Goettingen Posts: 2
    NerveGear
    hey there, after adding the app ID to Avatar and Platfrom settings there are still no hands showing up. Any idea what to do now?
  • yarwadyarwad Posts: 5
    NerveGear
    In the developer documentation it looked like you don’t have to enter an appID unless you want to use a custom avatar.  Anyone know if this is true?  It would suck if you have to request a new appID every time you wanted to experiment with Oculus in Unity
  • AndyPAndyP Posts: 1
    NerveGear
    I'm having the same issue with hands not showing up. None of the solutions seems to fix it. Not sure if I'm using 1.41 or 1.38 because I installed via the asset store, but the package manager seems to say 1.38.3 is installed. Not sure why it has to be this much trouble to get hands working on Quest considering how easy it was to get head tracking working, and I'm in total agreement that it would be extremely disappointing if an App id was required just to make a test project with hand tracking (although this hasn't solved the issue for me anyway).
  • CorysiaCorysia Posts: 92
    Hiro Protagonist
    Did you try my Example and it didn't work?
  • AGTDigitalAGTDigital Posts: 14
    NerveGear
    AndyP said:
    I'm having the same issue with hands not showing up. None of the solutions seems to fix it. Not sure if I'm using 1.41 or 1.38 because I installed via the asset store, but the package manager seems to say 1.38.3 is installed. Not sure why it has to be this much trouble to get hands working on Quest considering how easy it was to get head tracking working, and I'm in total agreement that it would be extremely disappointing if an App id was required just to make a test project with hand tracking (although this hasn't solved the issue for me anyway).
    Hello, make sure to use Unity 2019 versions because localAvatar  on Unity 2017 and 2018 are not supported for now.
  • rfunk82rfunk82 Posts: 10
    NerveGear
    edited November 10
Sign In or Register to comment.