Oculus Integration 1.39 not working for Quest in Unity — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Oculus Integration 1.39 not working for Quest in Unity

A couple weeks ago I built an APK for Oculus Quest using Unity. It was a build of the Oculus Integration package’s SampleScenes. This build worked, it was rather buggy but it worked. Then a few days ago there was the release of a new version of Unity (2019.2.0.f1) and a new version of Oculus Integration (v1.39). Since the updates, I have been unable to get the new versions to create a functional build.

When I output an APK using the Oculus Integration sample scenes, it does not run properly. The first time I loaded and ran the APK on the headset, it opened and ran the first scene (StartScene) with no problems, but when I tried to open the next scene it crashed. I was able to fix this by deleting the Android Manifest and then re-creating it. This let me open the next scenes but when I did nothing in the other scenes worked. The locomotion was not functional, the avatar hands were not connected to the controllers... none of the Sample Scenes I tried worked. ???

It’s important to note I have touched none of the code. I started with and empty 2019.2.0f1 shell set up for android and VR. Then I downloaded and installed the Oculus Integration Package v1.39 from the Unity Asset Store. I simply took the sample scenes provided by Oculus and loaded them into a build. I had to adjust the Player Settings for signatures and such, but those where the only modifications. One would think this should work. I had it working a few weeks ago.

Also the test build I did for Oculus Integration that worked and was on the headset, no longer functions properly at all. I did not reload it or touch this file in any way.

I feel Like I’m missing something. But what?


  • SnorchSnorch Posts: 3
    edited August 6
    Same problem, sample scenes from Oculus don't work well. Avatar hands not showing to me. I haven't touched ANYTHING, just installed Oculus Integration in 2018.4.5.
  • SnorchSnorch Posts: 3
    Well I solved it seems. They updated avatar scripts, a lot of them, but not all the prefabs. Some prefabs that previously worked now they do not. The only reliable one is LocalAvatar, that works well. And if you copy the settings of the script OVRAvatar from that to the old avatar prefabs they seem to work. Not in Windows though, that seem broken, but in Quest they work.
  • Studio_Ile_PariseauStudio_Ile_Pariseau Posts: 14
    I've managed to get a basic OVRPlayerController to kind of work. It jumps ahead one unit when you push the left hand joystick forward, then stops, you have to press the joystick repeatedly to move at all. What gives??? When will we see a new build from Oculus that fixes these issues?
  • ptmarksptmarks Posts: 3
    Same. Amazing. How can we develop like this? I can't even find a way to get back to 1.37. There seems to be no way to get to a working version of the Integration package. Please resolve this as soon as possible. Thank you.
  • wrcousertwrcousert Posts: 6
    Has anyone approached Unity about this? 

    Could someone upload a blank project that has uses 1.37?
  • ptmarksptmarks Posts: 3
    I was able to get movement working again by using a custom VRPlayerController (not the OVRPlayerController) adding an App ID and rebuilding the manifest file. See the forum comments link below for more information.

  • PhilzooomezPhilzooomez Posts: 14
    edited August 17
    I have the same issue  : Quest joystick not working since a few days. But only with the Quest, the touchpad of the Go works fine with the same build. As I am a VRTK user, I didn't upgrade to last Oculus integration version. Older builds, that worked fine before, dont work anymore with the quest, same issue. I am afraid this issue appeared after updating the quest to 7.1. Any help or idea mostly welcome !

  • Javed67Javed67 Posts: 3
    I just tried a demo on Oculus Quest with SDK 1.39. Everything is very wrong! I thought it would be like rift but no...both of my hand are not visible at the same time, one click one hand visibility!!! And movement is so damaging! I hope Oculus would solve these issues or upload a separate Quest, Rift, Go SDK. This is frustrating.
Sign In or Register to comment.