Why does changing the render resolution turn my Quest's screen black with spastic red flashes? — Oculus
IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Why does changing the render resolution turn my Quest's screen black with spastic red flashes?

RengeRenge Posts: 12
NerveGear
I'm trying to change the render resolution on my Quest app to test the impact on performance, but it doesn't seem to work.  The screen turns black and I get a dim red noise pattern flashing rapidly across the whole screen.

I'm using the exact code shown here or in other words just the single line:
UnityEngine.XR.XRSettings.eyeTextureResolutionScale = 1.01f;
The visual glitch happens when setting eyeTextureResolutionScale to anything but 1, even if it's only 1.01, or 0.99.  If I set it low enough, like 0.1, I also get a full frame of video about once per second before it goes back to mostly black.

This code is supposed to be usable on the Quest, right?  Because it works fine on the Go and the Oculus site doesn't say anything about it being incompatible with the Quest.  I'm using the Lightweight Render Pipeline in this app, could that be the problem?

Also, is there any other way to change the render resolution?

Best Answers

  • RengeRenge Posts: 12
    NerveGear
    Accepted Answer
    Just an update: this is definitely caused by the Lightweight Render Pipeline.  I can change the resolution no problem using the same project without the LWRP, it's only when the LWRP is in use that it causes this problem.  Seems to be a bug.  In other words, if you're using the Lightweight Render Pipeline you can't scale the render resolution at all.
  • RengeRenge Posts: 12
    NerveGear
    Accepted Answer
    I found a fix.  All I had to do was remove Vulkan from the Player rendering settings support list, even though OpenGL 3.0 was already at the top.  No more black screen.
Sign In or Register to comment.