Poor framerate after pausing and resuming with Oculus button on controller — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Poor framerate after pausing and resuming with Oculus button on controller

I was just testing out an application on the Go, getting it ready for store submission, and I noticed a new bug. The bug occurs while playing an application and pressing the Oculus button on the controller to pause the game and bring up the "quit/resume" Oculus menu, then clicking on "resume" to go back into the game. Upon resuming the framerate in the game begins stuttering horribly. Upon subsequent pause/resume actions, the app begins to stutter harder and harder, running at a very low framerate. At some point after multiple pause/resume actions, upon resuming, the application is back to running at what appears to be smooth framerates. However, continuing to pause and resume using the Oculus hardware pause button, brings the poor framerate and stuttering back into play. 

I tested this on multiple applications on multiple headsets and got the same result every single time. To rule out any scripts or objects in the scene causing the problem, I made an app that is a completely empty scene, save for a camera, and got the same framerate problems after using the Oculus button to pause/resume. I have submitted applications to the store in the past and have never seen this problem, albeit, they were on older versions of the Oculus Go, leading me to assume that this is a version problem. I even tested other applications besides my own like Altspace, Bait!, and even Dead and Buried and got the same results with those too.

Oculus Go version is: 8.0.0.135.626.168186885

I would provide the game engine version and Oculus SDK version, but previous games shipped used older versions than I am using currently and they ran fine then and poor now, further leading me to think it's Oculus version?
Sign In or Register to comment.