Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Error after upgrading from unity 2019.1.13f1 to 2019.2.5f1

VJ76VJ76 Posts: 46
Brain Burst
edited September 2019 in Unity Development
I'm working on a quest vr project, and i'm using Oculus Intergration 1.38

Recently i have updated the project to the latest unity version.
But after a build i get the following error.
I tried to renew the manifest, but it didnt work.

Anyone know how to solve this?

NullReferenceException: Object reference not set to an instance of an object
UnityEditor.XR.Oculus.OculusManifest.UpdateOrCreateNameValueElementsInTag (System.Xml.XmlDocument doc, System.String parentPath, System.String tag, System.String firstName, System.String firstValue, System.String secondName, System.String secondValue, System.String thirdName, System.String thirdValue) (at Library/PackageCache/[email protected]/Editor/OculusBuildProcessor.cs:60)
UnityEditor.XR.Oculus.OculusManifest.OnPostGenerateGradleAndroidProject (System.String path) (at Library/PackageCache/[email protected]/Editor/OculusBuildProcessor.cs:130)
UnityEditor.Android.AndroidBuildPipelineInterfaces.OnGeneratePlatformProjectPostprocess (System.String path, System.Boolean strict) (at C:/buildslave/unity/build/Editor/Mono/BuildPipeline/Android/AndroidPostGenerateGradleProject.cs:39)
UnityEngine.GUIUtilityprocessEvent(Int32, IntPtr)


  • wdwrightwdwright Posts: 4
    I'm getting the same error. 2019.2.6. Oculus Integration 1.4. Anyone have thoughts?
  • justdizzyjustdizzy Posts: 1
    edited September 2019
    I was getting this, tried a variety of checking and unchecking boxes but kept happening, finally I uncheck V2 signing, and build succeeded. Hope this helps get you too.
  • wdwrightwdwright Posts: 4
    That was it for me! Thanks!
  • wrobel221wrobel221 Posts: 1
    It's a bug in Oculus Android package.
    You can get a hint looking into the OculusBuildProcessor.cs script in the package. Cached in Library/PackageCache/[email protected]\Editor
    Check the line you get in the error's call stack. In your case it's OculusBuildProcessor.cs:130
    It can't handle required attributes like:

    <meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only"/>

    You can safely remove these attributes because these will be added automatically. The one that caused problems for me (no idea why) was vr_only meta-data.
Sign In or Register to comment.