Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Can not open AvatarSamples in Quest.

4252267242522672 Posts: 7
NerveGear
When I open \UnrealEngine-oculus-4.22.3-1.40.0\Samples\Oculus\AvatarSamples porject ,and Launch in Quest.
The App stop, and I got log .
D/UE4 : LogInit: - BufferSize = 65536
D/UE4 : LogOnline: Oculus: Oculus Startup!
D/UE4 : LogOnline: Display: Oculus: FOnlineSubsystemOculus::InitWithAndroidPlatform()
D/UE4 : LogOnlineIdentity: Warning: Oculus: Failed Oculus login. Not currently logged into Oculus. Make sure Oculus is running and you are entitled to the app.
D/UE4 : LogOnline: Display: OSS: OnlineSubsystemGooglePlayModule::StartupModule()
D/UE4 : LogOnline: Warning: OSS: FOnlineSubsystemGooglePlayModule was disabled
D/UE4 : LogOnline: OSS: Unable to create OnlineSubsystem module GooglePlay
D/UE4 : LogAndroid: Case APP_CMD_LOST_FOCUS
D/UE4 : LogAndroidEvents::EnqueueAppEvent : 10, 0, tid = 2631, APP_EVENT_STATE_WINDOW_LOST_FOCUS
D/UE4 : onPause: stop memory reporter runnable
D/UE4 : Unregistering sensor listeners
D/UE4 : Case APP_CMD_PAUSE
D/UE4 : LogAndroid: Case APP_CMD_PAUSE
D/UE4 : LogAndroidEvents::EnqueueAppEvent : 6, 0, tid = 2631, APP_EVENT_STATE_ON_PAUSE
D/UE4 : ==============> GameActive.onPause complete!

How Can I fixed it ?

1 Before update UnrealEngine-oculus-4.22.3-1.40.0 , everthing is ok. But now I change back to UnrealEngine-oculus-4.22.3-1.39.0 ,it still can not open new app in quest.
2 I am in china and can not connect to google

Comments

  • aussieburgerVRaussieburgerVR Posts: 226 Oculus Start Member
    Probably the target Android SDK version you are building for? What value do you have there?
  • DarkTableDarkTable Posts: 27
    Brain Burst
    For Unity's Oculus Integration, Arm64 avatars weren't available until recently (1.39?). This looks like the same error message I was getting when I tried to make and Arm64 build with Avatars enabled. Arm7 should work (but I don't know how set that in Unreal).
  • aussieburgerVRaussieburgerVR Posts: 226 Oculus Start Member
    show a screenshot your android settings under project settings. There you select arm7 or arm64 as well as your target android sdk version
  • 4252267242522672 Posts: 7
    NerveGear

  • aussieburgerVRaussieburgerVR Posts: 226 Oculus Start Member
    It should be target sdk of 25 according to the docs:
    but looking at your original problem perhaps it's due to an entitlement check you are doing? Are you doing an entitlement check? If so should remove it at least until you get accepted into the Quest development console ;)

Sign In or Register to comment.