IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Firmware 9 disabled developer mode?

The quest that we use a developer kit updated overnight to the new firmware and now we can't sideload anything. 
The Quest settings menu no longer displays a developer mode panel, despite it being enabled from the companion app. 

Any suggestions? 

Comments

  • NinjaGGNinjaGG Posts: 229 Oculus Staff
    @BitSpaceKev Welcome to the Oculus Developer Forums!

    There was a bug that affected some developers where updating to firmware v9.0 disabled the Developer mode within the companion app. Double check to make sure it wasn't turned off for you.
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
  • Leon-VR-LabLeon-VR-Lab Posts: 11
    NerveGear
    Interestingly when I started the Quest this morning (updated to firmware 9 overnight I guess) I had no "Unknown sources" tab anymore. Oddly enough I did have the developer settings in the settings menu on the Quest so I assumed Developer mode was still active. Turned out it wasn't. In the companion app, the Developer Mode was disabled. After enabling it, the Unknown Sources tab returned. It now also listed when doing "add devices", which it previously didn't. Weird behaviour but at least I can now continue.
  • OcubrickOcubrick Posts: 9
    NerveGear
    This happened to me as well, but also screwed up my ADB so my Quest isn't recognized when I plug it in anymore. The drivers update says they are updated, but device status is 'This device cannot start'
  • BitSpaceKevBitSpaceKev Posts: 2
    NerveGear
    NinjaGG said:
    @BitSpaceKev Welcome to the Oculus Developer Forums!

    There was a bug that affected some developers where updating to firmware v9.0 disabled the Developer mode within the companion app. Double check to make sure it wasn't turned off for you.
    We managed to get the Quests working again after the Firmware 9 update but now it's happening again for Firmware 10. I've already toggled the option in the mobile app and it's not enabling developer mode anymore. 
Sign In or Register to comment.