Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Oculus Avatar skin/hands is not transparent

lucybwlucybw Posts: 1
NerveGear

Using Unity 2019.2.5f1 I cannot get the Oculus Avatar hands/skin to render semi-transparent the way they used to. They render solid opaque grey.

This problem is both for Oculus Rift and Quest. I am focusing my testing on Rift because it was always working fine in my previous development, whereas I am just getting going on Quest.

I have tried both the legacy renderer in Unity and also the LWRP (URP).

I am testing on the LocalAvatar scene in Oculus/Avatar/Samples (and I have tried other test scenes). With Clean install of Unity and Oculus and Sample Framework etc.

OvrAvatar has an option "Use Transparent Render Queue". This is ON (and Unity restarted as required).

 

Details:

Unity version: 2019.2.5f1

Oculus Desktop plugin: 1.38.3 (also tried 1.38.2)

Stereo Render Mode: Multi-pass

 

I am having the same problem in Unity 2018.3.8f1

Suggestions anyone???

 

Answers

  • azinicus2azinicus2 Posts: 5
    NerveGear
    I'm having the same issue, but for me it's constantly throwing errors stating "Exception: No shader provided for avatar material." which is killing performance.
  • DarkTableDarkTable Posts: 27
    Brain Burst
    Avatars stopping being transparent "ghosts" a while ago. They are now solid with human skin colors. When you haven't loaded a user's avatar ID you'll see the default grey avatar. This all sounds normal.

    I'm not sure why the avatar still has the option use the transparent render queue. It might be to ensure that the avatar draws after all opaque geometry.

    To fix the "Exception: No shader provided for avatar material" I changed the Avatar's shaders so they're loading shaders from the lightweight render pipeline. You also have to make code changes so that they set "_BaseMap" and "_BumpMap" instead of "_MainTex" and "_NormalMap" in OvrAvatarMaterialManager.cs


Sign In or Register to comment.