Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Anyone using LWRP or URP for Quest?

AdamZ101AdamZ101 Posts: 20
Brain Burst
Anyone using Lightweight Render Pipeline or Universal Render Pipeline for Quest development? If so, what version of Unity and Oculus Integration are you using?

Thanks!

Comments

  • CorysiaCorysia Posts: 94
    Hiro Protagonist
    edited October 2019
    We were just having that discussion on Discord today.  Looks like one person has LWRP working in Unity 2018.4.5f1.  Another has tried in 2019.1 and 2019.2 without success.
  • mightycoconutmightycoconut Posts: 8
    Brain Burst
    I'm using it with 2019.2 but wouldn't recommend it. Had to jump through a lot of hoops to get it working, and every new feature I add seems to run into issues.
  • DarkTableDarkTable Posts: 27
    Brain Burst
    I'm using 2019.2.8 with LWRP 6.9.1. It works, but it is not ready for prime time. There's a (long) discussion about the issues we're having and some solutions in this thread:
    https://forum.unity.com/threads/fixed-foveated-rendering-on-oculus-quest-not-working.686662/

    Fixed foveated rendering requires a hack to work. You can't read from the "opaque texture" in shaders, so effects like glass/water refraction won't work. But you can get good looking stuff running at 72fps on Quest.
  • DarkTableDarkTable Posts: 27
    Brain Burst
    edited October 2019
    [that's a dupe]
  • FloVRDevFloVRDev Posts: 3
    NerveGear
    Hi everyone, someone tried URP with 2019.3b with the Quest ? 
  • DragnipurakeDragnipurake Posts: 2
    NerveGear
    I am making a custom SRP optimized for use on Quest, as opposed to using Unity's pre-built ones, and had that right eye is black issue too. I think it's a bug from blitting with "BuildinRenderTextureType.CameraTarget" where it only seems to target the left eye. Getting rid of rendering to a texture and blitting it fixes the issue (and will also make FFR work since it is broken with intermediate textures atm too).
  • KHANDREWKHANDREW Posts: 1
    NerveGear
    Hi!
    There are usage issues in Unity Oculus LWRP, Unity 2019.13f1
    After compilation, the camera in the right eye goes missing.  In Unity Editor, all cameras work.
  • eoin.mctecheoin.mctech Posts: 2
    NerveGear
    Right i missing is due to multipass, change to single pass to fix this in URP 2019.3
  • doubledandoubledan Posts: 12
    Brain Burst
    edited January 10
    As well as changing to single pass you also need to disable post processing. If you're using the Oculus camera prefab there is also an issue (2019.3 / URP) with anti aliasing causing the screen to black.

    Edit : Disabling "Use recommended MSAA level" on the OVR Manager script fixes the black screen issue for me
  • ROBYER1ROBYER1 Posts: 15
    Brain Burst
    I made this forum post on Unity forums where I had the XR Graphics Lead give some responses on this topic, (If you google search Unity forums + It's called 'Fixed foveated rendering on Oculus Quest not working' )
     I do recommend you take a look if you want to know what they are doing to fix this, it's still not working yet unfortunately
Sign In or Register to comment.