Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Oculus Quest Development Unity Problem

Saeed786129Saeed786129 Posts: 1
NerveGear
Hi, im having a problem creating a basic application in Unity for the oculus quest.
I cannot see my hands inside the application once it is on my Oculus Quest and i cannot move.

Here is a list of the steps I have taken:
 I have imported the Oculus Integration from the asset store.
 I have added the OvrPlayerController
 I have added a local avatar to the TrackingSpace inside the OvrPlayerController
 I have went to build settings, player settings
  In XR settings i have enabled virtual Reality supported and added the Oculus sdk
  Removed Vulkan from the graphics API
  Minimum api level set to kitkat

Developer mode is enabled on my Oculus quest and when i build and run i am inside the application.
The problems are
 1 i cannot see my hands, even though i added the local avatar
 2 I cannot move
When I run the application in unity I get 2 Errors:
XR OpenVR Error! OpenVR failed initialization with error code VRInitError_Init_PathRegistryNotFound: "Installation path could not be located (110)"

DllNotFoundException: libovravatar
OvrAvatarSDKManager: OnDestroy() (at Assests/Oculus/Avatar/Scripts/OvrAvatarSDKManager. cs:122)
  

When I run the application in unity a get 3 warnings:
  Virtual Reality SDK Oculus failed to initialize - will attempt to enable oculus instead
  Virtual Reality SDK Oculus failed to initialize - will attempt to enable OpenVR instead
  Virtual REality SDK openVR failed to initialise, will attempt to enable None instead.
 
If anyone knows how to solve this problem please help
   

Comments

Sign In or Register to comment.