Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Best shader and texture setting for lossless photo texture quality. (Oculus Go)

JepplenJepplen Posts: 3
NerveGear
edited November 7 in Unity Development
Hi,

Which shader and texture setting is the best to use on a plane with a photo on it to keep that photo at full quality or near lossless quality?
I have tried so many different and the image either comes out flickering or very blurry/low quality.

As in I want to display a photo and keep the quality true to it's original quality.
If there are better ways than applying it directly on a plane, I am all ears and would love to know how.

I am using Unity 2018.4.7f1 and the latest update of the Oculus integration asset. 
Oculus Go.

Comments

  • hcentenohcenteno Posts: 39
    Brain Burst
    edited November 7
    Did you try disabling mipmap generation in the import settings of your image and overriding the texture size for Android? Also try using an unlit shader or setting your image as the emissive texture.
  • JepplenJepplen Posts: 3
    NerveGear
    hcenteno said:
    Did you try disabling mipmap generation in the import settings of your image and overriding the texture size for Android? Also try using an unlit shader or setting your image as the emissive texture.
    I didn't know this option existed. I will try it out!
    I couldn't find out how to make the texture emissive, do you have any pointers for me?

    Also, should I use any HDR or Anistropic filtering, or is that a bad idea for large images as photos?
  • JepplenJepplen Posts: 3
    NerveGear
    I tried the "Override for Android", but it flickers and if I use mipmap the texture becomes very blurry.

    Here is gif image I made of how it looks inside the Oculus Go.
    This happens when I disable mipmap.



    I have tried texture settings: Default, sprite2D, GUI.
    mipmap on/off
    point (no filter)
    Bilinear, Trilinear
    No compression, High Quality, Normal quality
    Override for android, Max texture size 1024 (the image is 1024 24 bit), 24 bit, 32 bit, 16bit.

    Shaders: Standard, Legacy/Diffuse, Oculus texture2D Blit, Unlit texture, sprite/diffuse, sprite default, GUI and some more I don't remember.

    I have even tried to mix texture settings of sprite and shaders as GUI or standard texture and vice versa.
    Result is about the same.

    I don't know what I am doing wrong.
    I just don't seem to be able to maintain the image quality when building, sideloading and viewing it through the Oculus Go.

    The only time it doesn't flicker like that, is if I enable mipmap, but that makes the texture very blurry and looses plenty of quality.

    When I view the texture in Unity it looks perfect and at 100% full quality.



    What could it be?

Sign In or Register to comment.