Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Can't meet FPS requirement in build - EDIT: partial fix

jackblockjackblock Posts: 11
NerveGear
edited December 4 in Unity Development
Hi, After running the automated VRC tests in the oculus debug tool, i'm growing concerned about the ability to accurately test my framerate for oculus rift s.
The vrc testframerate fails, giving me an average of 67.5 fps (I should be hitting 80 for this oculus rift s). if I enable the performance hud and run the app again, i see conflicting statistics. Application GPU/CPU render times are about 3ms each, but the "app queue ahead" time is around 30ms? App framerate is shown perfectly locked at 60fps. If my total frame time is somewhere around 6-7ms, why am i getting a framerate at half that?

The first scene in my unity build is a nearly empty menu scene, just a skybox and a simple menu. This runs perfectly fine in the unity editor, and usually a non-editor build will always run a little faster. I've tried changing vsync settings, running the app with nothing else open, restarting my computer even, nothing helps me hit the required 80fps in a near empty scene!

Edit: I've upgraded from oculus integration 1.41 to 1.42, no change there. I also tried toggling the queue ahead option in the OVRManager component, didn't seem to change anything.

Here's me rendering an almost empty scene in unity editor, easily getting 100+fps

Unity 2019.2.1, windows 10 running a GTX 970, oculus integration from ap store version 1.41, will try upgrading to 1.42
Tagged:

Comments

  • jackblockjackblock Posts: 11
    NerveGear
    Gonna bump this again, I dont see any options available to me in order to pass the automated tests. What runs at 100+ FPS in editor locks to 60 in the build, even though it renders in sub 6ms time.
  • jackblockjackblock Posts: 11
    NerveGear
    here's my view of the testing scene, notice it's registering tons of frames as dropped, and the FPS is clamped exactly to 60.0hz even though CPU+GPU render time is less than 12ms (easily would be 80fps)
  • jackblockjackblock Posts: 11
    NerveGear
    Interesting discovery: If I bring another window to the front, after launching the built app (for example, alt tabbing back to the unity editor), the framerate cap goes up to 80fps! This means I can pass the test locally, if after starting the test I simply bring another window in front of the fullscreened app. However, this feels precarious and may still not pass the test on oculus' servers.

    Smells like a bug with matching the vsync to monitor instead of HMD, but only when the app is in the foreground.
Sign In or Register to comment.