Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Disabling OVRPlugin doesn't work properly

I'm working on a project for both oculus (OculusGo and GearVR) and cardboard platforms.
When I build for oculus paltform I can run the app with no problems.
When I build for cardboard I have no problem, but after installing, the icon doesn't appear in the Android app page, but only in the Cardboard application. In addition, if I run it from there it starts as GearVR app, showing the message which says to insert the smartphone in the GearVR.

I'm using Unity 2019.2.14f1 now, but this problem appears when update OVR integration SDK from v1.39 to any newer version (1.40, 1.41, 1.42, 1.43), regardless the unity version.

I didn't change any settings, just update OVR integration SDK from asset store, importing just Platform and VR folders, since I'm not using other features. Before importing the SDK I first remove the old one.

My settings for Cardboard build are the following:
- OVR plugins disabled
- Oculus -> Tools -> "User required project settings" is unchecked
- XR settings -> "Virtual reality SDKs" contains just Cardboard

Are there any setting I'm missing?
Sign In or Register to comment.