IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Hand tracking glitch after copying assets from HandsInteractionTrainScene and moving their position.

I copied the following assets to my own scene:
  • OVRCameraRig
  • Hands
  • InteratableToolsSDKDriver
I subsequently move all of them to another position simultaneously. After build, I can see that my hands/fingers are tracked but they are stretched to such an extent that they are unrecognizable. (Something alike to a upside down, blue spider with extremely long legs) They respond to my hand movements well and appear in the place of the OVR example I copied the assets from. My understanding is that I cannot move the Hands prefab from its position or something similar. But what is the source of the stretching?

Unity 2018.4.8f1
Oculus Integration 12.0

Kind regards

Comments

  • AuroraM5AuroraM5 Posts: 4
    NerveGear
    I rebuilt the scene where I didn't move any of the above game objects and it worked fine. However, it's good to know that that some of them aren't supposed to be moved. 
  • ChaplatoChaplato Posts: 4
    NerveGear
    This happened to me on the day I tried to build hand tracking in my own game. I spawned in the hand objects, and since my character was not initially on 0,0,0, I tried to move the hands to which it caused them to do the same thing described. 
Sign In or Register to comment.