IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Unity Hands not showing up in game

Im using Unity 2019.3.0f6, Oculus Integration 13.0 and my Quest is on version 13.0.0.

My problem is, when I build my scene to my Quest, the hands aren't showing, but I can still do the system gesture to close the program. I also tried the Traintestscene and the popup to enable hand tracking stays active even when I start the app with hands.

Setup:

Scene

OVRCameraRig


Hands Manager


Settings:

I also tried to create Oculus store-compatible manifest but still, no hands showing:

<uses-feature android:name="oculus.software.handtracking" android:required="true" /><uses-permission android:name="oculus.permission.handtracking" />

When debugging with Oculus Link, I found out that the variable IsTracked stays false. But the weird thing is, that I still can apply the Home gesture in game.

I find this very weird because I already did 2 other Oculus Handtracking Projects, and had no problems but since a week, I cant set up a new Handtracking project.
Sign In or Register to comment.