Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Enabling Oculus Quest's Hand Tracking in Unity XR Interaction Toolkit?

jormajejormaje Posts: 11
NerveGear
edited April 4 in Answers
XRCameraRig is supposed to replace OVRCameraRig but OVRCameraRig is the only place where you can set hand tracking support ("Hands only" or "Controllers and hands"). That option is not available on XRRig so including hands makes the app to be recognized by Oculus Quest as a "hands only" app.
  • How can I use both hands and controllers in a UnityXR app?
  • If it's not possible, will it be possible in the future?

Comments

  • jormajejormaje Posts: 11
    NerveGear
    edited April 4
    Finally I solved it. Don't use the new XR Management System.

    Remove the following packages:
     - XR Management
     - XR Interaction Subsystems
     - Oculus XR Plugin

    Install the following packages:
     - Oculus Android (2.38.6)
     - Oculus Desktop (2.38.4)
     - OpenVR Desktop (2.0.5)
     - XR Legacy Input Helpers (1.3.11)

    Change the AndroidManifest:

     - Make sure this line is missing:

        <meta-dataandroid:value="false" android:name="com.oculus.vr.focusaware" >
        </meta-data>

     - Make sure hand tracking is not required:

        <uses-feature android:name="oculus.software.handtracking" android:required="false">

     - Make sure intent-filter category is LAUNCHER, not INFO:

        <intent-filter>
        ...
        <category android:name="android.intent.category.LAUNCHER"></category>
        </intent-filter>

     - Make sure you only have these meta-data elements:

        <meta-data
        android:name="unityplayer.SkipPermissionsDialog"
        android:value="false">
        </meta-data>
        <meta-data
        android:name="com.samsung.android.vr.application.mode"
        android:value="vr_only">
        </meta-data>

    I hope we could change hand tracking and controllers while using the new XR Management System in the future
  • UmbrinoxUmbrinox Posts: 7
    NerveGear
    Hey, so as a newbie, should I be using OVR over the XR Interaction Toolkit?
  • El_inEl_in Posts: 24
    Brain Burst
    Just gave XR Interaction Toolkit another try and I don't see any progress on my side since I tried it last time.

Sign In or Register to comment.