IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

I Can't Test My Quest App in the Unity Editor with XR Plug-in Management

OjosLindosOjosLindos Posts: 19
Brain Burst
Unity ver. 2019.3.14f1.  Android platform.  The XR Plugin Management and Oculus XR Plugin packages, latest Oculus Integration, and Android SDK, etc., are installed.  Everything seems to be properly set up for XR.  If I sideload a build into my Quest the app plays there.  But when I play the app in the Unity editor all I see in my Rift headset (which I'm trying to use for testing) is the Oculus Dash.  Am I missing something simple?

Comments

  • buck.schroeterbuck.schroeter Posts: 5
    NerveGear
    Did you download the XR Interaction toolkit preview package in the package manager?  (You have to make sure previews are visible in the package manager screen)
  • JeffNikJeffNik Posts: 173
    Art3mis
    edited June 3
    If you want to use the Rift to test your Quest/Android apps, I think you have to switch from android back to stand-alone mode in the project settings dialog, and double check that the XR Plugin management  settings are correct after the switch. I think it should also work in Adnroid mode if you have LINK enabled, but I could be wrong.


  • OjosLindosOjosLindos Posts: 19
    Brain Burst
    edited June 3
    Thanks to both of you for your feedback!

    #buck.schroeter:  I haven't yet downloaded the XR interaction toolkit package but can do that.  Do you think that would help me test in my Rift in the Unity editor with the project set to the Android platform?

    #JeffNik:  It would be unfortunate if I have to switch back to stand-alone, because it takes a long time to switch platforms in my project.  I don't recall having to switch back to stand-alone to test in my Rift with Unity's previous XR system, but maybe this is the price to pay for progress.  But can you tell me how to enable LINK?
  • JeffNikJeffNik Posts: 173
    Art3mis
    edited June 3
    Hey, pretty eyes :) ... I agree - switching back and forth takes a very long time to recompile all the assets. I'll do a few tests on my side and let you know what I find... are you using URP, HDRP or the standard old built in 3D pipeline?
  • JeffNikJeffNik Posts: 173
    Art3mis
    Ok... tried a few things, and here's what I found:

    1) To enable LINK - just have oculus home open on the PC, and connect your Quest to the PC with a USB-C cable like the one that came with your Quest (preferably USB 3 or above, but apparently USB 2 should work, as well). You should see prompts on the Quest screen and the PC screen about enabling LINK. Accept all prompts and make sure Quest is listed in Oculus Home on the PC under devices. Link should be enabled now - meaning that in the Quest you should see the RIFT VR menu, not the Quest home menu, and you could play your Rift games on the Quest if you wanted to. Leave the Quest plugged in to the PC.

    2) For my test in Unity, I used the standard 3D pipeline (AND URP worked too). Created a brand new project, switched to Android platform, enabled the XR Management plugin, ticked the "Oculus" button. I added a "Tracked Pose Driver" script to the main camera so it would track the headset without using the Oculus Integration package from the Unity Store. Then I hit play in the editor - Quest did NOT display the game, and the editor did NOT track the headset.

    3) I went back to project settings, switched platform BACK to standalone. I then noticed that the XR Management plugin was installed, BUT the "Oculus" option was UNCHECKED. I checked it (while in standalone), then switched back to Android platform and hit PLAY in the editor again. This time, the game played in the editor, and the headset tracked, AND the game was playing in the Quest headset.

    Assuming that you don't NEED to test in your Rift, and that testing on your actual Quest is acceptable, try this: Endure the long compile and switch to the standalone platform once. I would guess you'll see that "Oculus" is unchecked in the XR Management plugin. You should just have to check it, then switch once more back to Android, and your game should run on the Quest over LINK, and your editor window should be tracking your headset. 

    Crossing my fingers for you... :-)




  • xeniaeoxeniaeo Posts: 1
    NerveGear
    edited July 1
    Ran into the same problem using Quest and Unity 2019.3.3f1, tried @JeffNik's solution to switch back to standalone, check "Oculus" and then switch back to Android and it worked! I can hit play in editor and test it in the headset via link cable. Thanks!
  • hansthemanhanstheman Posts: 1
    NerveGear
    I did have these problems as well and got the advice to downgrade XR to the earlier version. But maybe this will work as well :D
    Alternatively you can disable XR all together and go back to earlier Oculus Android VR SDK found in the Package Manager.
  • kavanbahramikavanbahrami Posts: 5
    NerveGear
    edited August 19
    @JeffNik , I don't believe you need to switch targets, just go into Project Settings > XR Plug-in Management, and click the little computer (imac/monitor) icon to access standalone builds, and then toggle Oculus on in addition to android.
  • mightycoconutmightycoconut Posts: 11
    Brain Burst
    Yes no switch necessary, just enable the Oculus plugin on the standalone build.
  • Goose316Goose316 Posts: 1
    NerveGear
    Can confirm the most recent posts - You can leave your build setting on Android, you only need to tick the Oculus box for PC settings (see @kavanbahrami post above)
Sign In or Register to comment.