Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Getting a black screen when following Quest tutorial in Unity

R0dluvanR0dluvan Posts: 9
Brain Burst
I've been trying to follow the instructions under "Develop>Oculus documentation>Unity>Get Started" on Unity 2019.4.4f1, but while the app works fine in the editor preview, when I start it from "Unknown sources" on the Quest, I invariably see only a black void. I can interact with the guardian fine. If I put the HMD to sleep and wake it up again, I briefly see a flash of the standard Unity sky and ground scene before the void shuts everything out. I've tried recreating a project from scratch and I get the same phenomenon out of the box. I initially had not created an XRRig in the hierarchy, but doing so (and deleting the old main camera) has had no effect.
I also tried replacing the XRRig with an OVRCameraRig, but that changed nothing.
Is there a tutorial for developing for the Quest on Unity 2019.4 (that works)?

Answers

  • mike.andryauskasmike.andryauskas Posts: 1
    NerveGear
    I'm also having this issue with version 18.0 with 2019.3. Also pressing the Oculus button doesn't do anything within the app, and restarting the headset is required.
  • R0dluvanR0dluvan Posts: 9
    Brain Burst
    +1 on the oculus button not working.
    I did manage to get my app running, by first downgrading Unity to 2020.3.15f1 (which in itself didn't help) and then manually importing Oculus Integration version 17 instead of 18. Now I don't know if I could repeat the process, I don't remember every setting I adapted, but it worked the first time I tried building it, after that.
  • wonderhallwonderhall Posts: 1
    NerveGear
    same too
  • HITLABHowestHITLABHowest Posts: 1
    NerveGear
    Using Unity 2019.4 LTS and downgrading to Oculus Integration version 17 fixed the issue.
  • FrickHazardFrickHazard Posts: 1
    NerveGear
    Same issue for me now attempting to downgrade package to 17.  Would love to see the underlying cause.  So far have spent 10 hours debugging this.
  • ShaomaiShaomai Posts: 4
    NerveGear
    edited July 27
    That sounds likely an known issue which described on the release note of Oculus Unity Integration:

    Note: You may encounter issues when running ARM7 build on Oculus Go or Oculus Quest, if you are using Unity's XR Management system with the latest OVRPlugin and the Oculus XR Plugin is outdated. In such case, you can either switch to ARM64 build, or upgrade the Oculus XR Plugin to 1.4.0+ to fix the issue.



  • PsilosyberPsilosyber Posts: 1
    NerveGear
    I really hope this is fixed in V19. Until then using V17 seems to work.
  • halloumipizzahalloumipizza Posts: 1
    NerveGear
    Running Unity 2019.3.x. V20 did not work and probably neither did V19. However, V17 did.
  • laniaxlaniax Posts: 1
    NerveGear
    What worked for me, on Unity 2020, was opening the package manager, expanding the Oculus XR Plugin and upgrading to version 1.4.0. (Apparently installing the plugin installs version
Sign In or Register to comment.