IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

unity compile oculus quest app but only black screen appears

juanma.ferrermartinjuanma.ferrermartin Posts: 2
NerveGear
edited July 26 in Oculus Quest Development
hi, im using unity 2019.4.5 and when i tried to compile for oculus quest after this message: No activity found in the manifest with action MAIN and category LAUNCHER.
Your application may not start correctly.  
app dont launch on headset, but apk its copied, i then launch manually and only black screen appears...dont load any scene...any help? please

Comments

  • hashtag_paleohashtag_paleo Posts: 1
    NerveGear
    edited July 26
    im getting started with oculus quest development and I'm having the same issue. To add to this, when i turn off/on the quest i can see my scene just for a split second before everything goes black.

    I am trying to accomplish this super basic tutorial from the official docs "Build your first VR App:"

  • Juan.F.ErazoJuan.F.Erazo Posts: 3
    NerveGear
    edited July 28
    This is also happening to me. I am using 2019.4.4f. I've been doing a lot of research on this topic and everything I find seems to relate to older versions.

    No activity found in the manifest with action MAIN and category LAUNCHER.

    Is also the message I'm getting. 

  • Juan.F.ErazoJuan.F.Erazo Posts: 3
    NerveGear
    The black screen issue went away after I uninstalled the Oculus desktop app that I was using for Oculus Link. I noticed it kept opening when I built to the headset. It also started around the time I got Oculus Link working. I can't think of any other factors at play. Please confirm if this fixed it for you as well!
  • Travi1sTravi1s Posts: 1
    NerveGear
    edited July 31
    Also having this issue, tried to resolve the issue on my own but no solution, is there any way to make this work?
  • ribrib Posts: 14
    Brain Burst
    Also been starting to see this problem (with 2019.4.4f1 and the latest Oculus Integration Asset). I first saw the issue about a week ago but at the time there was also a new version of the Oculus Integration Asset that had just been published and when I upgraded the issue seemed to fix itself. Maybe it was somehow a bit of a coincidence that it apparently fixed itself last week - maybe it wasn't related to the new version of the asset. Now I'm already on the latest version of the asset I'm not sure what to try and this is stopping me from being able to share test builds of my application on the Quest :(
  • SplicedDNASplicedDNA Posts: 45 Oculus Start Member
    Exact same thing happening to me. Happened after I got the latest version of the Oculus Integration from Asset Store. Any solutions yet?
  • SplicedDNASplicedDNA Posts: 45 Oculus Start Member
    I confirm it is fixed when downgrading back to Oculus Integration 17
  • LhgLhg Posts: 1
    NerveGear
    I still have this issue. Oculus SDK 18 (tried 17 and didnt work). Unity 2019.4.6f (latest LTS). Everything compile and even run under Link/PC. But when the apk is generated for android and sent to the quest it displays a black screen.
Sign In or Register to comment.