Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Personalized avatars are not working

Hi,

I have been following the official oculus tutorial to show personalized avatars but it doesnt work. Only the bald dude is showing all the time.
I have been trying to make a new project, with the latest Oculus SDK, still doesnt work. 
In the Avatar Gallery scene, provided by oculus, all the avatars look the same(that bald dude).

Does anyone know any solution?

Thank you

Comments

  • kojackkojack Posts: 7,211 Volunteer Moderator
    DirtyFred said:
    Hi,

    I have been following the official oculus tutorial to show personalized avatars but it doesnt work. Only the bald dude is showing all the time.
    I have been trying to make a new project, with the latest Oculus SDK, still doesnt work. 
    In the Avatar Gallery scene, provided by oculus, all the avatars look the same(that bald dude).

    Does anyone know any solution?

    Thank you

    I just ran into this as well (while trying to teach a class how to get local avatars working). I've got a valid app id in Unity (in both avatar and platform settings). I tried even entering my credentials manually. Following the tutorial didn't work. Even running the Oculus Integration samples won't do it, for example the Avatar Gallery that should show 10 test avatars just shows the metal bald guy 10 times. It takes time for each to load (they pop up one by one) so it seems to be networking, but the end result is just the one default avatar.

    I also tried a stand alone build (so not in editor).

    The avatars themselves work fine (got hand animation and lip syncing working), it's just the wrong meshes and materials.
    Author: Oculus Monitor,  Auto Oculus Touch,  Oculus Forum Tool,  Phantom Touch Remover,  Forum Dark Mode,  X-Plane Fixer
    Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
    Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2
  • kojackkojack Posts: 7,211 Volunteer Moderator
    I just checked the latest C++ avatar sdk.
    It's sample app is broken too, it never passes the entitlement check and therefore never tries to load an avatar. So it just renders a grey void.
    I rolled back from 20.1 to 19.0. Same thing.
    I then discovered the Mirror sample application id is no longer valid. I changed it to my own application id and now it renders... the same default bald avatar as the Unity samples.

    Looking a little deeper, Entitlement is passing successfully, but ovr_GetLoggedInUserID() is always returning 0, so it always loads a default avatar. In Unity, getting the user packet had my correct user name ("kojack") with an ID of 0.
    But even if that was the problem, that doesn't explain why hard coded test avatar ids in the Oculus gallery sample all fail too.

    I see threads on here going back to august about this issue, no resolution so far.

    Author: Oculus Monitor,  Auto Oculus Touch,  Oculus Forum Tool,  Phantom Touch Remover,  Forum Dark Mode,  X-Plane Fixer
    Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
    Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2
  • puffosauropuffosauro Posts: 6
    Brain Burst
    I've got the same problem.
    I would like to know if you need to Complete a Data Use Checkup even if the application is not submitted to the Store (my application is used inside my organization).
    Also developers should be able to test the application before release it.


  • DirtyFredDirtyFred Posts: 2
    NerveGear
    kojack said:
    I just checked the latest C++ avatar sdk.
    It's sample app is broken too, it never passes the entitlement check and therefore never tries to load an avatar. So it just renders a grey void.
    I rolled back from 20.1 to 19.0. Same thing.
    I then discovered the Mirror sample application id is no longer valid. I changed it to my own application id and now it renders... the same default bald avatar as the Unity samples.

    Looking a little deeper, Entitlement is passing successfully, but ovr_GetLoggedInUserID() is always returning 0, so it always loads a default avatar. In Unity, getting the user packet had my correct user name ("kojack") with an ID of 0.
    But even if that was the problem, that doesn't explain why hard coded test avatar ids in the Oculus gallery sample all fail too.

    I see threads on here going back to august about this issue, no resolution so far.

    I am sorry to hear that this issue goes deep.

    Can you tell an estimation when it will be fixed? Should i reach out on other forums or submit somewhere this as a bug so the developers can fix it?
  • supercourgettesupercourgette Posts: 1
    NerveGear
    Any news?
Sign In or Register to comment.