Fixing UE defaults — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Fixing UE defaults

kamau00kamau00 Posts: 43
NerveGear
edited March 2016 in Unreal Development
I am in the process of learning UE4 to port my game (The Stacks) to it.

There are a lot of oddities to configuration that needed adjusted. My hope is that this helps others starting to use UE4 for Oculus Rift development:

#1. The scale of default door and frame are wrong. The door is 200cm tall. That is 6.56 feet. Doors in my house are 6.8 feet. This means you need it to be 208cm. That is a scaling factor of 1.04. That doesn't mean I'm going to use their door frame but if you are using that to gauge if scale is correct in the game, 3 inches is a big deal. I felt like my head was scraping the top of the door.

#2. I'm 5 foot 8. The default height for a player is much taller. To adjust this go to the MyCharacter blueprint, click default and search for height. you want to set "capsule half height" to 1/2 your height in centimeters. My height is 172cm/2 = 86.

The next set of adjustments require a post processing volume. You can find it in "All Classes" if you don't have one. Drag it into your scene. search for unbound detail and check that so it applies to everything.

#3. There is a blur as you approach objects. This is an anti-alias method of temporal and it is super annoying. search the post processing volume for AA Method. Set that to none.

#4. Lens flare has to go. Search for Lens and set the Intensity and BokehSize to 0.

#5. Scenes in the rift get unusually bright. That is auto exposure. Search for exp. I don't know exactly the best settings but I am using min brightness = .5, max brightness = 1, auto exposure = 0.

The other thing that bothered me was the IPD feels different. Up to now I hadn't adjusted it on the DK1. UDK3 felt perfect. I had to adjust it for UE4 to make it not give me a headache.

That is a start I will update this thread when I am deep into development and have sorted through any other unpleasantness.

My initial impression with UE4 versus UDK3 is that it doesn't feel as nice in the Rift. UDK3 felt like Half Life 2 which was very 'crisp'. UE4 feels more 'fuzzy' like Unity. UE4 certainly comes packed with more flexibility but it feels like a step back for Rift support.

Comments

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Interesting findings. Thanks for sharing.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • chelseariftchelsearift Posts: 13
    NerveGear
    Thanks man this helped me with my brightness issues
  • knackknack Posts: 356
    kamau00 wrote:
    #1. The scale of default door and frame are wrong. The door is 200cm tall. That is 6.56 feet. Doors in my house are 6.8 feet. This means you need it to be 208cm. That is a scaling factor of 1.04. That doesn't mean I'm going to use their door frame but if you are using that to gauge if scale is correct in the game, 3 inches is a big deal. I felt like my head was scraping the top of the door.

    The standard door tall in my country its 200cm

    #4. Lens flare has to go. Search for Lens and set the Intensity and BokehSize to 0.

    you check with the rift? i like that effect, its a real effect, anyway i will try decreasing when i can check with DK2
    PD: yes my english its bad i known

    i5-4570 - Shaphire r9-290, win10-64
  • owenwpowenwp Posts: 681 Oculus Start Member
    Disabling auto exposure is not a great solution. It means that you have to give up contrast between indoor and outdoor areas, and physically-based lighting values become unusable. There should be settings to adjust it to be darker, or maybe there is a bug.
  • artyom17artyom17 Posts: 319 Oculus Staff
    A lot of useful info here, thanks! Keep posting VR tips to this topic (making it sticky)
  • n00854180tn00854180t Posts: 323
    There's a separate PostProcess volume in the Landscape demo for 4.4 labeled GlobalPostProcessOculus - has different settings than the normal one, and seems to still have auto exposure enabled (but with different settings).

    I don't have a DK2 yet so I can't test it, but that might be a good place to start for the post processing.
    Storyteller: Fireside Tales - An immersive VR audiobook player.

    The VR Dungeon Survival Project - First person 3D roguelite survival game.

    Twitter
    IndieDB
  • RirathRirath Posts: 23
    Thanks for bringing this thread back, missed it the first time around.
  • spyrospyro Posts: 338
    Art3mis
    edited August 2014
    #3. There is a blur as you approach objects. This is an anti-alias method of temporal and it is super annoying. search the post processing volume for AA Method. Set that to none.

    Temporal aliasing gives fantastic results in VR as it kills nearly all the annoying pixel crawling. I would not recommend to deactivate it.

    spyro
  • n00854180tn00854180t Posts: 323
    spyro wrote:
    #3. There is a blur as you approach objects. This is an anti-alias method of temporal and it is super annoying. search the post processing volume for AA Method. Set that to none.

    Temporal aliasing gives fantastic results in VR as it kills nearly all the annoying pixel crawling. I would not recommend to deactivate it.

    spyro

    Really? I'm surprised it looks good in VR considering how badly it looks on a monitor, with the weird jittery pixel swimming effect it causes.

    Not saying I don't believe you, I'm just surprised (don't have my DK2 to test it myself yet).
    Storyteller: Fireside Tales - An immersive VR audiobook player.

    The VR Dungeon Survival Project - First person 3D roguelite survival game.

    Twitter
    IndieDB
  • GigantoadGigantoad Posts: 395
    Nexus 6
    spyro wrote:
    Temporal aliasing gives fantastic results in VR as it kills nearly all the annoying pixel crawling. I would not recommend to deactivate it.
    spyro

    That's not true actually: https://wiki.unrealengine.com/Oculus_Rift#Texture_Blurring_.2F_Vibrating

    Maybe you meant FXAA?
  • spyrospyro Posts: 338
    Art3mis
    I know that article. But I tried it for myself with a modified Temple Demo (viewtopic.php?f=32&t=14018, press T to toggle TAA). Don't know if they fixed some bugs in then meantime but it looks fantastic there. Not noticed any kind of texture vibrating but some cruelsome pixel crawling with FXAA and some issues with reflections (regardless of the aliasing method).

    spyro
  • mrgreen72mrgreen72 Posts: 683
    Art3mis
    kamau00 wrote:
    #1. The scale of default door and frame are wrong. The door is 200cm tall. That is 6.56 feet. Doors in my house are 6.8 feet.
    Do you really mean 6.8 feet or 6'8"?

    6.56 (almost 6'7") seems about right to me...
  • bjw88bjw88 Posts: 3
    Nick Whiting and Nick Donaldson on Epic's VR team gave a talk last year that included some steps on setting up a project for VR. They didn't cover size metrics like this post, but had some interesting information on setting up engine defaults. The video is here:
    .

    Here's a link to the slide deck: https://de45xmedrsdbp.cloudfront.net/Resources/files/UE4-Integration-and-Demos_OC-100270768.pptx

    And here's the defaults Nick Donaldson recommends using in the DefaultEngine.ini render settings:
      r.SeparateTranslucency=0 r.HZBOcclusion=0 r.FinishCurrentFrame=1 r.MotionBlurQuality=0 r.PostProcessAAQuality=3 r.BloomQuality=1 r.EyeAdaptationQuality=0 r.AmbientOcclusionLevels=0 r.SSR.Quality=1 r.DepthOfFieldQuality=0 r.SceneColorFormat=2 r.SSSSS=0 r.TranslucencyVolumeBlur=0 r.TranslucencyLightingVolumeDim=4 r.MaxAnisotropy=8 r.LensFlareQuality=0 r.SceneColorFringeQuality=0 r.FastBlurThreshold=0 showflag.decals=0 r.SSR.MaxRoughness=0.1 r.compileshadersfordevelopment=0 r.rhicmdbypass=0 r.TiledReflectionEnvironmentMinimumCount=10
  • saviorntsaviornt Posts: 1,951
    NerveGear
    Here are the GameEngine.ini settings from the ShowDown VR demo that was released:

    [SystemSettings]
    r.VolumeMultiplier=1.0
    r.screenpercentage=130
    r.SeparateTranslucency=0
    r.HZBOcclusion=0
    r.FinishCurrentFrame=1
    r.MotionBlurQuality=0
    r.PostProcessAAQuality=3
    r.BloomQuality=1
    r.EyeAdaptationQuality=0
    r.AmbientOcclusionLevels=0
    r.SSR.Quality=1
    r.DepthOfFieldQuality=0
    r.SceneColorFormat=2
    r.SSSSS=0
    r.TranslucencyVolumeBlur=0
    r.TranslucencyLightingVolumeDim=4
    r.MaxAnisotropy=8
    r.LensFlareQuality=0
    r.SceneColorFringeQuality=0
    r.FastBlurThreshold=0
    showflag.decals=0
    r.SSR.MaxRoughness=0.1
    r.compileshadersfordevelopment=0
    r.rhicmdbypass=0
    r.TiledReflectionEnvironmentMinimumCount=10

    [Oculus.Settings]
    bLowPersistenceMode=true
    bUpdateOnRT=true

    [/Script/Engine.RendererSettings]
    r.MobileHDR=True
    r.AllowOcclusionQueries=True
    r.MinScreenRadiusForLights=0.030000
    r.MinScreenRadiusForDepthPrepass=0.030000
    r.PrecomputedVisibilityWarning=False
    r.TextureStreaming=True
    Compat.UseDXT5NormalMaps=False
    r.AllowStaticLighting=True
    r.GBuffer=True
    r.GenerateMeshDistanceFields=False
    r.Shadow.DistanceFieldPenumbraSize=0.050000
    r.TessellationAdaptivePixelsPerTriangle=48.000000
    r.SeparateTranslucency=False
    r.CustomDepth=0
    r.DefaultFeature.Bloom=True
    r.DefaultFeature.AmbientOcclusion=True
    r.DefaultFeature.AutoExposure=True
    r.DefaultFeature.MotionBlur=True
    r.DefaultFeature.LensFlare=False
    r.DefaultFeature.AntiAliasing=2
    r.EarlyZPass=1
    r.EarlyZPassMovable=True
    r.ClearSceneMethod=1
    r.MSAA.CompositingSampleCount=4
    r.WireframeCullThreshold=5.000000
  • dummumdummum Posts: 3
    NerveGear
    Good info, thanks!
  • motorsepmotorsep Posts: 1,370 Oculus Start Member
    What would be the settings for Gear VR for maximum performance ? (using standard materials and no dynamic lights; only baked lighting)
Sign In or Register to comment.