Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

[SOLVED] DK2 in UE4 standalone player not working

ConzConz Posts: 83
Hiro Protagonist
edited March 2016 in Unreal Development
Hi,

my DK2 is working with all demos (incl. the oculus configuration demo).
I can run the VR-Preview in UE4 (UE 4.10.4 and 4.11 preview 7), but in a standalone player the VR feature is missing.

All VR commands in the console are not recognised.
If I check "ovrversion" in the console of the standalone, then I get the following message:
"Command not recognised: ovrversion"
(The same for "HMD Enable" or "stereo on")

I have asked the same question in the Unreal forum, but got no reply, yet.
https://forums.unrealengine.com/showthr ... alone-game

Do you have any idea, what I have do to fix this?

Windows 7 64bit
980ti
Oculus 0.8 Runtime
UE 4.10.4 and 4.11 preview 7

Comments

  • vrdavebvrdaveb Posts: 1,596 Oculus Staff
    Did you build with Oculus Rift support enabled? There is a plugin you need to include. See https://wiki.unrealengine.com/Oculus_Rift.
  • ConzConz Posts: 83
    Hiro Protagonist
    Yes, the plugins are activated (Screenshot).

    I can add VR Blueprints, IMHO that should proof, that the plugins are available, but only in the Editor.

    I have tested some of the sample scenes (like CouchKnights), same effect. VR is working in VR-Preview, but not in the standalone Game.
  • artyom17artyom17 Posts: 319 Oculus Staff
    I believe this is designed behavior (by Epic): you use VR Preview for VR (and you can switch between stereo/mono using console commands) and Standalone for regular runs. However, it would be interesting to hear from Epic what do they think about this. I can see why you would want to start your game in mono and switch to VR later.
  • ConzConz Posts: 83
    Hiro Protagonist
    As I wrote, the console commands are not available, that is the strange thing. Looks like the VR-Lib ist not included in the created standalone game.
    Conz wrote:
    All VR commands in the console are not recognised.
    If I check "ovrversion" in the console of the standalone, then I get the following message:
    "Command not recognised: ovrversion"
    (The same for "HMD Enable" or "stereo on")
  • artyom17artyom17 Posts: 319 Oculus Staff
    Just let clarify that you are talking about the "Standalone game" preview mode in the Editor. If you run it as a real standalone game (not from the Editor) - it works fine. The reason why - Epic runs the "Standalone game" preview with the option -nohmd, and this is why you don't have an ability to use any VR-related console commands. This is done intentionally, I believe.
  • ConzConz Posts: 83
    Hiro Protagonist
    Ah, that would explain it. Thank you.
    Have to try it, and I'll give response later.

    EDIT: It's working with a compiled standalone Game! Thank you for your help.
Sign In or Register to comment.