VST Wont Open — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

VST Wont Open

CFlicksterCFlickster Posts: 12
edited March 2016 in Audio SDK Development
Hello,

Having some trouble opening the VST of the Oculus Spatializer plug in. Most applications (Peak Pro, Adobe Audition, etc.) don't even recognize the plug in. When I try to open it with Max/MSP I get the following errors:

Max 5 Error Message:
vst~: OculusVST.vst: plug-in initialization error

Max 7 Error Message:
OculusVST.vst: no format VST exists

Furthermore when viewing the package contents of the OculusVST plug in, there seems to be something different about the file in the MacOS folder.



Here is my system info for reference.


I've placed the OculusVST file in the global plug ins folder for the computer, and started and restarted apps and the computer just for kicks but not getting any results.

Can anyone shed some light on this?
Thanks in advance!

Comments

  • Tried again on my work machine. 3.4 GHz Intel Core i7 OS X 10.9.5

    Same issue :(
  • DaveDriggersDaveDriggers Posts: 114 Oculus Staff
    Hi,

    Sorry you're having trouble. We actually haven't tested the plugin in any of the applications you mentioned - though we have verified it works in just about every major DAW. The file in the MacOS folder is the binary executable. I believe the difference in the icon is due to an unrecognized (or missing) symlink, but i doubt that would be an issue with the plugin being recognized by the host. This sounds more like a code signature verification issue. What version of the plugin are you using? We only just started code-signing the VST in 1.0.0-beta, previous version were unsigned. We never ran into signing issues with the VST, but for the AAX, we did have to digitally sign the plugin in order for Pro Tools to recognize it. This could be the case with Max, Adobe, etc. If you're on an older version, please grab the latest version and let us know if it works (https://developer.oculus.com/downloads/ ... K_Plugins/).

    Thanks,
    -dave
    dave driggers | audio programmer | Oculus VR
  • Hi Dave,

    Thanks for the reply! I only found out about the plug in last week so I think it should be up to date. I'll make sure I get the latest version just in case, and report back. I'll also get my hands on a demo of some DAW and make sure my computer isn't being wonky. A colleague just confirmed it works for him using Cubase so I know its just some combination of what I'm doing and my set up.

    Thanks again!
    Cody
  • Tried again with the latest version of the plug ins. Still same errors. Can't install Cubase demo because their system req is 10.9

    I think my system being older might be part of the issue, but I've already tested the latest version of MaxMSP with a 10.9 system, so I don't want to upgrade quite yet. Max isn't really a common asset creation software but it's a good program for dynamically controlling parameters and prototyping systems for audio you've already created. It would be really awesome to be able to use the VST within Max, but I'm sure there are more important things the team is working on.

    Gonna try and dig on the Cycling74 forums to see if anyone can come up with a solution there.
  • any updates on this?

    just installed the Audio SDK 1.0.2 and having similar(ish) issues.
  • petergiokarispetergiokaris Posts: 170 Oculus Staff
    Hi IsolateUK,

    I tried the latest VST plug-in from our dev site (1.0.2) for OSX, using El Capitan (V10.11.3) in Ableton Live Lite 9. It was correctly loading up.

    Did you add the VST into the following location:

    /Library/Audio/Plug-ins/VST

    Which DAW are you currently using?

    Thanks
    Peter Giokaris
    Senior Software Engineer
  • alemusicaalemusica Posts: 11
    Hi, I have latest vet version of the plugin and it works just with ableton, not max/msp 7 or Usine hollyhock (another great modular daw). Please help me to fix that.
Sign In or Register to comment.