Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

thread priority security exception make sure the apk is signed?!

I created a new empty project with Unity 5.1.1p2 and generated the signature file for my device via oculus tool on the website (ID is correct via monitor, adb devices and shows on the pushing bar when compiling with unity)

I also signed the app with a new keystore i generated in the publishing settings of unity

I get that error when running the app in the GearVR - "thread priority security exception make sure the apk is signed" and then it throws me to the GearVR app store

What should i do with this?

Best Answer

  • jkimovr-ahubjkimovr-ahub Posts: 2
    Accepted Answer

    Yes, please manually create this folder path -


    This path is unchanged but is not created automatically when using Unity first party support for VR.


  • noemis-ahubnoemis-ahub Posts: 2

    Same problem here: Today I got the Samsung Gear and I would like to test the unity vr integration, but Samsung S6 says after start with gear: "Thread Priority Security Exception - Make Sure The APK Is Signed".

    The setup: New 3D project using Unity 5.1.1.p2 and Gear VR, enabled Virtual Reality Support and the Oculus sig file is in the assett folder. Any ideas? Are there more people with this problems?

  • noemis-ahubnoemis-ahub Posts: 2

    @HaimWA: My problem was solved in a Unity Forum. You have to put the sig file not in the standard Asset folder from Unity. Copy it in the Unity Assett Folder in the following subfolder: Plugins/Android/assets

    I attach a screenshot for all how think about where to put the oculussig file. unity511p2-oculussig.png

  • dmidmi Posts: 0


    I am developing an application for the Samsung Gear VR and I am using
    Unity5.3.0f4 and OculusUtilities_0_1_3_0_beta

    After starting the Application with my Samsung Gear and Samsung S6 Edge plus
    the following error occures "thread priority security exception make sure
    the apk is signed"

    In my Unity Project I have integrated the OSIG File in the following directory
    ..Project\Assets\Plugins\Android\Assets ... this means that my app is signed

    Another question is if this signature file is not only bound to
    a special Device ID but also to a specific user?

    I have also checked my apk with the check_submission.exe (see
    the attached check.jpg)

    I am looking forward to your answer bzw. sollution of this




  • devinsweidingerdevinsweidinger Posts: 6
    Brain Burst

    I'm having the same issue with testing on an empty cube scene.

    I created a new keystore.
    (Player Settings > Publishing Settings)

    I downloaded Oculus sig files for both my Android Device ID and IMEI
    (Found IMEI by dialing Dial *#06# and used this app for my Device ID)

    I'm using Unity 5.3.0f4. I have Unity Pro for PC, but I don't have the Pro license for Android.

    I can not figure out what i'm doing wrong. I've been messing with this for hours.

    Edit: Apparently using IMEI is not longer valid. I managed to figure it out that the app I used to get the Device ID was not valid, worked once I got the Device ID from the shell commands.

  • dmidmi Posts: 0

    Hi, seems I have solved the problem. It is very important to use the "adb devices" command instead of an app to receive the number of the device. I have an samsung s6 edge plus and with the "adb devices" command I receive the HARDWARE ID instead of the DEVICE ID ... and boom using this HARDWARE ID it is working!

  • montynayyarmontynayyar Posts: 1
    I solved this problem by following the steps as below - 

    1) Got the device ID using the App SideloadVR DeviceID from Android Playstore
    2) Used the device ID to generate the oculus signature file using the service at https://developer.oculus.com/osig/
    3) Copy the signature file generated in step 2 at the following location in your Gear VR Unity Project - Project / Assets / Plugins / Android / assets 

    Now build and Run the App on the Android Device and should be able to get rid of this issue.
  • Abrar1Abrar1 Posts: 2
    hi , I'm having the same issue with testing on an solar system scene but I have not a folder called Android in my Plugins folder "so I created one" any Ideas why this folder is missing?
  • ChristineZhengChristineZheng Posts: 9
    Hi, I am having the same issue with "thread priority security exception make sure the apk si signed". I have followed the instructions to place the oculus signature file under path Assets/Plugins/Android/assets. But still getting this message and can't see my app in the headset. I downloaded an app called Device ID to get the device ID and use that to download oculus signature file. I have been searching for many days still can't figure out what is going on! Please help me!!
    I'm using Unity 5.4.2f2, samsung galaxy s7, the next-generation gear vr headset, have virtual reality supported enable. 

  • ChristineZhengChristineZheng Posts: 9
    Nvm, i got it! It was bc I had the wrong device ID #. Don't know why, but the ID # I got from the app Device ID was not working. 
  • pennguypennguy Posts: 2
    edited March 2017
    Montynayyar , after getting my device id and placing it to the specified assets folder, it's safe to say I'm still getting the same old frustrating error message. When I build and run the apk goes directly to my phone which means the osig file is being read and excepted but still no progress in viewing my app on vr gear.  Anyone else can help please.  
  • pennguypennguy Posts: 2
    edited March 2017
    I still have the same old frustrating error message. After following directions. Any other suggestions? Could it be a build settings problem? Please someone help.
  • Sir_LockSir_Lock Posts: 1
    Old Thread, but it popped up when I was looking for the answer so here it goes: Something I've noticed after a couple hours trying get my windows 10 pc to launch adb.exe (and failing) and finally switching to my macbook to obtain the Device ID is that on the Samsung S8+ OS 7.0 you can see the Device ID list under: Settings > About Phone > Service Provider SW ver. [2nd line down will be your long ID, mine was 18 digits of letters and numbers] I hope that saves people time. Also, You can verify you have the correct number when launching the Build and Run. Unity will display the Device Id followed by the Model Number of your device. (Unity 5.6.1f1)
  • suleymanciftci003suleymanciftci003 Posts: 1
    If someone still have the same Problem as lock3113 said " Unity will display the Device Id followed by the Model Number of your device. " last section of building. printscreen and note that. Onlay that helped me. DeviceID programs work bad...
    Thanks lock3113
  • markusffsanimarkusffsani Posts: 1
    HELP! Wer can i finde the Folder: Gear VR Unity Project - Project / Assets / Plugins / Android / assets.....i didn't find it....
    Or better, what for a software need i to get this Folder?

Sign In or Register to comment.