Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Unable to load DLL 'ovrplatformloader'

delphinius81delphinius81 Posts: 297
Nexus 6
edited July 2017 in Unity Development
I recently switched my project to use the oculus unity tools distribution through the Asset store. In preparation for this, I removed all previous dlls and files related to unity tools and the platform sdk. After importing the store version of the sdks and building a GearVR application, I am now seeing the following error in the logcat for my application. I am using Unity 5.6.2p2, with android tools 25.2.3 to build the application. I have also instructed Unity to use OVRPlugin v 1.14.1.


07-26 15:58:45.129 17712 17731 D Unity   : Unable to lookup library path for 'ovrplatformloader', native render plugin support disabled.

07-26 15:58:45.129 17712 17731 E Unity   : Unable to find ovrplatformloader

07-26 15:58:45.140 17712 17731 I Unity   : DllNotFoundException: Unable to load DLL 'ovrplatformloader': The specified module could not be found.

07-26 15:58:45.140 17712 17731 I Unity   :   at Oculus.Platform.CAPI.ovr_UnityInitWrapper (System.String appId) [0x00000] in <filename unknown>:0 

07-26 15:58:45.140 17712 17731 I Unity   :   at Oculus.Platform.Core.Initialize (System.String appId) [0x00000] in <filename unknown>:0 


For a while, it was necessary to have some svcloader file in /Plugins in order for the Platform dll to properly load. However, this file seems to be missing from the last two platform unity packages. Any ideas as to why the platform will no longer load on Android?

Comments

  • delphinius81delphinius81 Posts: 297
    Nexus 6
    edited July 2017
    Ugh, figured it out. This is actually due to the asset store version of the plugins/tools including conflicting DLLs for the built-in oculus audio spatializer plugin. You guys should probably include a way to update the version of the spatializer used by unity, similar to how the utilities plugin dll can be updated.
  • santamannosantamanno Posts: 1
    NerveGear
    @delphinius81 Can you please advise on how to solve the issue? I'm trying the social starter example, right out of the box, no upgrades or anything, and it fails with that message... Thanks!
  • WahooDevColtonWahooDevColton Posts: 4
    NerveGear
    @delphinius81 Could you please elaborate on your fix? I am also getting this issue.
  • Anzac360.comAnzac360.com Posts: 1
    NerveGear
    Ugh, figured it out. This is actually due to the asset store version of the plugins/tools including conflicting DLLs for the built-in oculus audio spatializer plugin. You guys should probably include a way to update the version of the spatializer used by unity, similar to how the utilities plugin dll can be updated.
    Please let me know the specific step you took to solve?
  • paulsinnettpaulsinnett Posts: 3
    NerveGear
    For me, the fix was to set the platform to ARM64 but I was building for the Quest.
Sign In or Register to comment.