Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Crash in the Wwise Oculus Audio Spatializer

Hello,

We are using the Oculus Audio Spatializer plugin 1.18 for Wwise 2016. When we have more than 64 sounds playing through the Oculus plugin and we try to play an ambisonic sound, we crash in the ConsumeInput function.
This issue seems to occur only with ambisonic sounds. If we try to play a standard sound, it's handled correctly and doesn't crash.

I'm at your disposal if you need more informations to reproduce this bug.
Thanks.


Comments

  • petergiokarispetergiokaris Posts: 170 Oculus Staff
    Hi Benjamin,

    Thanks for finding this issue. I believe I can repro it. I will take a look and see what's happening and let you know what's going on.

    Best,
    Peter
    Peter Giokaris
    Senior Software Engineer
  • Charlie.ataCharlie.ata Posts: 22
    Brain Burst
    edited October 2017
    Hi Peter.

    There is more information on this crash.
    It happen here à 100% if we have more than 64 sounds playing in addition to an ambisonic sound, even if the 64 sounds are virtualized in Wwise.

    I guess the plug-in doesn't make a difference between active sounds and virtualized sounds.
    Can you give us a confirmation please?

    Best,
    Charlie.

    Wwise V2016.2.0
    Oculus spatializer 1.18 and 1.19


Sign In or Register to comment.