Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Pause game when Oculus home was pressed (App rejected)

rfunk82rfunk82 Posts: 10
NerveGear
edited November 2017 in Unity Development
My app was rejected because it fails to "When bringing up the Universal Menu, the gameplay should pause in the background."

Is this a setting that I have to enable/disable? or somewhow I need to create this behavior from scratch?

Thanks!

Comments

  • rfunk82rfunk82 Posts: 10
    NerveGear
    Also, I did uncheck "Run in background" from Player Settings, but it did nothing, game still runs when I press the Oculus Home button
  • rfunk82rfunk82 Posts: 10
    NerveGear
    This seems to happen only in the unity editor. I ran the game outside of the editor (.exe) and it works fine.
  • justin.wasilenkojustin.wasilenko Posts: 33
    Brain Burst
    edited November 2017
    You need to pause the game itself using something like this:

            //Pause the AudioListener
            AudioListener.pause = true;

            //Pause the game by setting time to 0
            Time.timeScale = 0.000001f;
  • gritourbano1gritourbano1 Posts: 5
    Brain Burst
    edited March 2019
    Someone could fix it?
    I unchecked run in background, but the app is still not paused when the user removed the HMD.
Sign In or Register to comment.