Proper use of "get user profile" data. Height, IPD, etc...? (Blueprint) — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Proper use of "get user profile" data. Height, IPD, etc...? (Blueprint)

OlivierJTOlivierJT Posts: 190 Oculus Start Member
Hello everyone,

The first thing is to enable Oculus plugin "Online Subsystem Oculus"
And then use a "Get user profile" , break it and print those.

But... nope.
It returns "true" but the values are still default (Unknow, 0, 0.1 etc...)

What am I missing?

Thanks

Comments

  • OlivierJTOlivierJT Posts: 190 Oculus Start Member
    Tested on Mint 4.20.3 (from UE4 Git) and on 4.20.3 OVR (From Oculus Git)
  • aussieburgerVRaussieburgerVR Posts: 214 Oculus Start Member
    This isn't working for me either - I was trying to get the user profile name but returns empty
  • wirelitesoft.devwirelitesoft.dev Posts: 62 Oculus Start Member
    This isn't working for me either - I was trying to get the user profile name but returns empty
    i submitted a bug about this and it was confirmed. they still working on it. in 4.20.3 it gives the profile id not the name.
    I too am waiting this to be fixed.

  • wirelitesoft.devwirelitesoft.dev Posts: 62 Oculus Start Member
    edited October 2018
    ooops i thought you said get oculus identity srry
  • aussieburgerVRaussieburgerVR Posts: 214 Oculus Start Member
    edited October 2018
    ooops i thought you said get oculus identity srry

    I had tried this as well and it also comes up empty.

    Is the oculus subsystem setup correctly in my defaultengine.ini I wonder?:

    [OnlineSubsystemOculus]
    bEnabled=true
    OculusAppId=123456789

    where the appid equals the one in the oculus dev dashboard
  • NeontopNeontop Posts: 216 Oculus Start Member
    defaultengine.ini I wonder?:

    [OnlineSubsystemOculus]
    bEnabled=true
    OculusAppId=123456789

    where the appid equals the one in the oculus dev dashboard
    I'm using a rift so I have added 
    OculusAppId= ###
    RiftAppId=####
    And it is working. 

  • aussieburgerVRaussieburgerVR Posts: 214 Oculus Start Member
    Neontop said:
    defaultengine.ini I wonder?:

    [OnlineSubsystemOculus]
    bEnabled=true
    OculusAppId=123456789

    where the appid equals the one in the oculus dev dashboard
    I'm using a rift so I have added 
    OculusAppId= ###
    RiftAppId=####
    And it is working. 
    which version of the engine and oculus sdk are you using?
Sign In or Register to comment.