Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

[Go / Gear VR] Nodes 'Has Input Focus' and 'Get VR Focus State' not working as intended

maro87mqmaro87mq Posts: 12
NerveGear
edited July 2018 in Unreal Development
Hello!

I'm having trouble pausing the game using either 'Has Input Focus' or 'Get VR Focus State' blueprint node (and passing certification).
I'm also using 'Has System Overlay Present' to check and pause the game if the Oculus overlay is displayed (which works fine). I've checked this on Unreal binary distribution 4.18 and 4.19.
Current behaviour is that after about 10 seconds from removing the headset the game pauses but it does not pass certification so I assume there has to be abetter way or something is wrong?

I was also looking at 'UnrealSample' from Oculus SDK but couldn't find anything related to pausing the game in that situation.

Behaviour is implemented inside Game Mode blueprint, the actors that supposed to pause have the 'Tick Even if Paused' disabled.
If anyone has some ideas or samples (blueprint or c++) that could show the working way to do this I will be very thankful.

My implementation (also tried 'Get VR Focus State' in place of 'Has Input Focus'):

Best Answer

  • maro87mqmaro87mq Posts: 12
    NerveGear
    Accepted Answer
    It does work in game mode (game mode is present on every level).

    What's more, the solution I've posted works correctly (was not mentioned in review result).
    As suggested by the reviewer I've enabled dash mode ( https://developer.oculus.com/documentation/unreal/latest/concepts/unreal-dash/ ), which should be just different pause display mode. So I'm guessing either the review process is not consistent or the documentation is wrong.

Answers

  • wirelitesoft.devwirelitesoft.dev Posts: 66 Oculus Start Member
    edited July 2018
    This is how i got it to work for me.
    without both on success and the normal execute pin going to the set paused my game always started paused. no mater how i put it it was paused till i did this...

    I don't think you can do this in a gamemode. It has to be in every level blueprint you have... that's how I got it to work tho

    Image:


    and in world settings do tick this


  • maro87mqmaro87mq Posts: 12
    NerveGear
    edited July 2018
    Edit: lag double post
  • maro87mqmaro87mq Posts: 12
    NerveGear
    edited July 2018
    Edit: lag double post
  • StoolfeatherStoolfeather Posts: 1
    NerveGear
    When I set game paused, it stops the tick so it doesnt check again. Any solutions to this?
  • HejdenHejden Posts: 8
    NerveGear
    There's a blueprint node called "SetTickableWhenPaused" that you set to "Target: Self", which will allow the blueprint you're in to keep firing the Event Tick even when you've set the game to paused.
  • wirelitesoft.devwirelitesoft.dev Posts: 66 Oculus Start Member
    Hejden said:
    There's a blueprint node called "SetTickableWhenPaused" that you set to "Target: Self", which will allow the blueprint you're in to keep firing the Event Tick even when you've set the game to paused.
    this is not allowed by oculus. game must always pause if the user removes the headset........
Sign In or Register to comment.