Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

trouble getting started with Avatars (Oculus Go)

JoeS2018JoeS2018 Posts: 28 Oculus Start Member
...which suggests that after you drag out the LocalAvatar prefab into your scene, adjust the position/rotation, switch it to Third Person, and check Start With Controllers, you should run on the device.

It doesn't describe what you should see at that point, but presumably you should see something. But I got nothin'.  No sign of any avatar anywhere.

This is even after creating an app and downloading it from an alpha channel, so the platform SDK can be properly initialized and authorized.
No obvious avatar-related messages in the logcat... so I'm not sure what to try next.  Any ideas?

(Unity 2018.2.15f1; latest Oculus Integration stuff from the Asset Store.)
Tagged:

Comments

  • JoeS2018JoeS2018 Posts: 28 Oculus Start Member
    OK, apparently the documentation's claim that the avatar should be at Y=0 is just wrong.  That puts the avatar below the floor.  Placing the avatar at Y=1.7 (same as the camera, and well above the floor) makes it visible.

    Also, for future reference, if you define a ENABLE_AVATAR_LOGS scripting symbol, then the avatar system will suddenly start outputting useful log messages (see OvrAvatarLogger.cs).

  • treeviewstudiostreeviewstudios Posts: 39
    Brain Burst

    i think the problem is in the method that handles the "Pose", its getting 0 for head position, so you should add the height offset (1.7 or whatever you want), and the avatar should relocate, instead of hacking positions, this might be a better option.

    check this out https://forums.oculusvr.com/developer/discussion/72431/easy-fix-for-avatar-height-on-oculusgo-gearvr#latest
Sign In or Register to comment.