Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

APK is signed with Signature Scheme V3, which is not yet supported.

InpuInpu Posts: 55 Oculus Start Member

I have this error since this morning using the command tool to upload APKs. It was working fine yesterday. I've always been using the same build and project since the beginning. Is something going on ?

It seems I'm not the only one (https://forum.unity.com/threads/apk-is-signed-with-signature-scheme-v3-which-is-not-yet-supported-oculus-platform.613405/).




  • InpuInpu Posts: 55 Oculus Start Member
    There's more people impacted by the hours on the Unity thread. For some a Gradle build is working, but I'm unable to make a Gradle build for some reason. Please help :(
  • InpuInpu Posts: 55 Oculus Start Member
    edited January 16
    Managed to make a Gradle build, but now it's telling me that I should use the same key as for my previous build, so I guess that won't be an option !
  • wraithwonwraithwon Posts: 11 Oculus Start Member
    I am having the exact same issue. Just uploaded fine a day or two ago, nothing changed in my process.
  • InpuInpu Posts: 55 Oculus Start Member
    I finally made it work using jarsigner thanks to a tips on the Unity topic ! Today has been a crazy ride for many dev it seems :/
  • davidpppdavidppp Posts: 1
    We were able to successfully avoid this error by uploading an apk built with Gradle (via Unity Build Settings).
  • wraithwonwraithwon Posts: 11 Oculus Start Member
    edited January 16
    I switched from internal to gradle and it started letting me upload again. The real mystery is why did this suddenly started happening despite no change in my build process or unity version?

    PS: I was getting a weird MIPS architecture error when I switched to gradle that caused it to fail to build. I went in an renamed (or delete) my android ndk folder and it fixed that error.

  • spacefrogspacefrog Posts: 55
    Hiro Protagonist
    edited January 17
    Experience the same . I thought this had to do with my Java SDK update to V1.8.0_202 which i did before the build . Did you guys update ( or let it autoupdate ) Java too before ?
    Anyways - i was able to fix my issue by using the jarsigner ( from the JDK bin folder ) to resign the apk with V1 scheme.
    The syntax ( commandline, though i made a batch script which lets me drag and drop the apk onto it ) for this would be:
    jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 -keystore <KEYSTORE> -storepass <STOREPWD> -keypass <KEYPWD> <APKFILE> <ALIASNAME>
    The parts in bold ( including the enclosing  <...> ) should of course be replaced with your specific values

  • NinjaGGNinjaGG Posts: 234 Oculus Staff
    Thanks for the heads up, I've notified our engineering team and will update you all here once there is progress.
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
  • stevehinanstevehinan Posts: 129
    spacefrog said:
    jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 -keystore <KEYSTORE> -storepass <STOREPWD> -keypass <KEYPWD> <APKFILE> <ALIASNAME>
    Thank you spacefrog, you are awesome.
    Your workaround worked for me. 
  • GifgroenGifgroen Posts: 2
    My guess would be that there was an Android sdk update that enforced this behaviour? That's the only variable in this case if you ask me. Did somebody else update there Android Studio or Android SDK after which this started happening?
  • jinhaifengjinhaifeng Posts: 6
    I've had the same issue with uploading my builds to the Go/ Gear release channels, been following a few threads where people have said the same thing, this is the first one I saw where Oculus will be looking into it. Some people suggested switching to Gradle but that didn't work for me, maybe it'll work for others? , I'll try another couple things in the interim while we wait on Oculus.
  • SebaGoRkSebaGoRk Posts: 1
    I had this problem today and after downgrade the Android SDK the problem is gone when i make internal builds.
    I'm with the 27.0.3 SDK version now.
  • robocatrobocat Posts: 14
    Hey, has this ever been resolved? I ran into this issue today with an update to my app based on the Unity LTS version 2017.423f1. Did manage to upload using a gradle build, but that binary unfortunately refused to run properly (crashed at startup in some native rendering code?).
    After freaking out for a while, I solved my issue by doing an internal build and signing it using jarsigner.
  • treehousenorristreehousenorris Posts: 11
    jarsigner after building with unity's gradle gives this error:

  • stevehinanstevehinan Posts: 129
    edited June 7
    @treehousenorris&nbsp; I think the jarsigner workflow is for Unity Internal builds and the Gradle workflow is to modify your gradle template file. (it's possible I'm wrong, but it would be a first)
Sign In or Register to comment.