Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Oculus Unity Integration - v1.39 (07/26/19)

NinjaGGNinjaGG Posts: 238 Oculus Staff
edited September 2019 in Unity Development

Version 1.39 of our integration for Unity has been released!

The Oculus Integration for Unity package adds scripts, prefabs, samples, and other resources to supplement Unity’s built-in support. The package includes an interface for controlling VR camera behavior, a first-person control prefab, a unified input API for controllers, advanced rendering features, object-grabbing and haptics scripts for Touch, debugging tools, and more. For more information, see our Unity Getting Started Guide.

You can grab the latest version of our Unity Integration here (through the Unity Asset Store): https://assetstore.unity.com/packages/tools/integration/oculus-integration-82022

More information, as well as general known issues with Unity, about this release can be found here.

New Features

  • Updates Mixed Reality Capture support:
  • The Unity Profiler now supports GPU profiling on Oculus Quest and Oculus Go, see the Testing and Performance Analysis page for additional information.

Integration Changes

  • Updated the Oculus Unity Integration to 1.39, including:
    • Updated the Audio Spatializer to 1.39
    • Updated the Lipsync integration to 1.39
    • Updated the Platform integration to 1.39
    • Updated the Avatar integration to 1.39

Known Issues

Previous versions of the Unity Integration can be found here: https://developer.oculus.com/downloads/package/unity-integration-archive/

The thread for the previous version (v1.38) can be found here: https://forums.oculusvr.com/developer/discussion/77572/oculus-unity-integration-v1-38-06-21-19
If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
2. Please submit a ticket here (include what you've gathered in step 1).
3. Tag me @NinjaGaijin once you have done so!


  • RingorjoRingorjo Posts: 3
    This Release Solves the problem with the controls of the oculus quest?
  • dilmergamesdilmergames Posts: 2
    Ringorjo said:
    This Release Solves the problem with the controls of the oculus quest?
    I am running into the same issues as the comment above, looks like the Oculus Quest is not detected and also the OVRControllerPrefab is not swapping to the Oculus Quest controller.
  • x_gurux_guru Posts: 2
    As a developer looking at the quest as a possible platform the total screw up and as yet unaddressed problems with the controllers is making me think it's a fool who wants to develop for it, clearly Oculus don't give a damn.
  • NinjaGGNinjaGG Posts: 238 Oculus Staff
    edited July 2019
    If you are experiencing issues with your projects due to the latest firmware and integration update, please rebuild your manifest file.

    For Unity:

    1. Within the Unity editor, remove the current manifest by clicking on Oculus -> Tools -> Remove AndroidManifest.xml

    2. Generate a new AndroidManifest by clicking on Oculus -> Tools -> Generate store-compatible AndroidManifest.xml

    For Unreal/other engines:

    Please include the following line in your existing AndroidManifest.xml:

    <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" />
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
  • blackfox.studioblackfox.studio Posts: 19
    I'm experiencing problems after upgrading the Unity Integration from v1.38 to v1.39

    --- My App ---
    The app is pretty simple:
    - Few grabbable 3d models and a UI Canas with a button in front of the user
    - Parabolic teleport using the left controller thumbstick
    - Laser pointer which becomes visible when pointing at the UI Canvas using the right controllers

    -- My System -- 
    Oculus Quest (firmware updated to July 2019)
    MacOS Mojave
    Unity 2019.1.12f
    Oculus Integration v1.39

    -- The Problem -- 
    I can evince that both controllers seem working (although I cannot see my hands anymore) because I can see when I cross the Guardian Grid with each hand. However:
    1) Right controller: The laser pointer which should be visible only when pointing to a UI element is now always visible (although colored in black instead of the one I did set for it). 
    2) Left Controller: The teleport stopped working but when I try to activate it using the thumb-stick (as programmed) I can clearly see a laser pointer at coordinates (0,0,0) appearing as a flat line (typical of when you want to customize it using the prefab)
    3) Grabbing stopped working for both of them
    Question: Shouldn't only one controller be working If the headset was in Oculus Go mode?

    --- What I tried --- 
    1) removed the app using ADB
    2) removed and regenerated the Android Manifest with the Oculus > Tools 
    3) AndroidManifest.xml wasn't affected but it contains the line <uses-feature android:name="android.hardware.vr.headtracking" android:required="true" android:version="1" />
    4) AndroidManifest.OVRsubmission.xml was regenerated and it didn't have the requested line so I added 
    <uses-feature android:name="android.hardware.vr.headtracking" android:required="true" android:version="1" />
    5) Checked the Unity Player Settings --> Settings for Android --> Other Settings --> Identification 
    Minimum API level: 23 (Marshmallow)
    Target API level: Highest Installed (Automatic)
    Source: https://developer.oculus.com/documentation/quest/latest/concepts/mobile-native-manifest/

    As instructed, I have filed a ticket with all the required logs. However, a reply to this post might help all those experiencing the same problem. Thanks!
  • Blitz64Blitz64 Posts: 8
    edited July 2019
    Oculus 1.39 makes the Avatar hands invisible.   
    Just try to load the "AvatarGrab Sample Scene" from this tutorial:

    I can still grab the oculus blocks.   Just the hands are invisible.  Maybe the hand mesh disappeared.

    -- My System -- 
    Oculus Quest (firmware updated to July 29 2019)
    Windows 10
    Unity 2019.1.12f1
    Oculus Integration v1.39

    Edit 7/31/2019.  I was able to get my invisible hands back.   I needed to put my app id from dashboard.oculus.com in both Oculus -> avatar and Oculus -> platform.    
  • blackfox.studioblackfox.studio Posts: 19
    Latest update: I have been running the sample projects inside the oculus framework. I think the problem is with the LocalAvatarGrab (hands are not visible in that scene). CustomHands scene displays the hands correctly. 
  • blackfox.studioblackfox.studio Posts: 19
    The only way to make hands appear is to get OVRCameraRig and the custom hands in the scene. No way to use OVRPlayerController and make hands work. On top of that, the floor level is misaligned even if I have set the "Tracking origin type" to floor
  • jstarrdewarjstarrdewar Posts: 19
    We are still having the problem where in the Unity Editor, on only two out of six of our Windows desktop machines, the Oculus integration fails to initialize and the only way to be able to continue working is with the OpenVR fallback. We rolled back to 1.37 to avoid the problem in 1.38, but we now need some of the 1.39 improvements.
  • hawkenhawken Posts: 21
    Brain Burst
    I'm also having the problem with missing hands, all the sample scenes with avatar objects like body and hands don't show on the quest after build (manifest rebuild, controllers show)
  • blackfox.studioblackfox.studio Posts: 19
    @hawken, I was able to get the hands back but it seems like you cannot use OVRPlayerController. Try to open the Custom Hands scene, get the Camera rig and hands and copy into your scene. It's the only thing who worked for me so far. The problem is that I need OVRPlayerController for the teleport (all the tutorials I found to use that). If anybody knows how to implement it using only OVRCameraRig that would be very useful
  • BarbadelBarbadel Posts: 4
    I've finally managed to get my hands to appear in my game but all credits goes to Valem on youtube.
    So this is his solution:
    "Since 25/07, the new version 1.39 of the Oculus Integration has changed how the Local Avatar works. Here is the fix : To see your avatar, you have to register an oculus app id. On the top panel go to Oculus / Avatars / Edit Settings, you can create an oculus app id here https://dashboard.oculus.com/ (useful if you want to make some multiplayer stuff or publish to oculus store) BUT any number as the Oculus App ID will also works !"

    So its that simple... enter an App ID, rebuild and your hands should now appear...
  • jstarrdewarjstarrdewar Posts: 19
    Apparently if like me you are suffering from "failure to initialize" errors and you aren't getting hand/head tracking in the Unity Editor, you can roll just the "Spatializer" folder back to the 1.37 version. It appears that Spatializer is the culprit for us. Thanks to Etienne Archambault for noticing that https://forums.oculusvr.com/developer/discussion/comment/698867/#Comment_698867
  • GigaSoraGigaSora Posts: 13 Oculus Start Member
    Did gaze targets stop working for anyone else? Mine throws:

    NullReferenceException: Object reference not set to an instance of an object
    System.Runtime.InteropServices.Marshal.WriteInt32 (System.IntPtr ptr, System.Int32 val)

    For each object. As far as I know you just attach the gaze target script and it should work while working with the avatar system. Did before.
  • GigaSoraGigaSora Posts: 13 Oculus Start Member
    It looks like that error is thrown for just the first ovrAvatar_UpdateGazeTargets call. Before nativeGazeTargetsData is set. So it's not a huge deal. A little annoying though.
  • Laney74Laney74 Posts: 1
    Using the Integration package in Unity in a high school classroom.  We were able to test the OVRPlayerController by holding down CTRL+WASD and checking locomotion (while also being able to check environments being built) - this meant we didn't need a Headset on each computer - the 1.39 update doesn't seem to do that anymore...or does it?  Anyone know if the ability to preview without the Headset feature still exists?
  • roberthendry84roberthendry84 Posts: 4
    the platform SDK 1.39 download on this page: https://developer.oculus.com/downloads/package/oculus-platform-sdk/1.39.0/
    is an html: ovr_platform_sdk_1.39.0.zip.html 
    Am I supposed to change the file to just a .zip to get it to work? Or is it a bug?
  • roberthendry84roberthendry84 Posts: 4
    edited August 2019
    Actually I guess that version isn't for Unity anyway... well the real problem is that for the last 2 days I've been trying to get the unity Oculus Integration 1.39 to work, but my scripts can't find the namespace 'Oculus' so the scripts can't use LeaderboardEntry or even Oculus.Platform at all. The files are all located where they were before the upgrade so something is wrong. Any help would be greatly appreciated :)

    Edit: I am reimporting all unity assets because all of the scripts are not processed yet after bringing them all back in. I will try to just 'comment out' the Leaderboards script after the 2 hour reimport has finished and see if that will help it see the Oculus namespace.

    Edit 2: My files have processed and they still can't find 'Oculus' namespace! What is going on? :(

    So basically I either need my files to find the 'Oculus' namespace with the updated Oculus Platform (Fix 1), or for checking Entitlements to actually get called in my older code (Fix 2). Please can someone find an answer? I would be eternally grateful :)
  • mnsmutsmnsmuts Posts: 1
    I'm also having a problem with missing hands. Using Rift and Unity 2019.1.2f1. I have a valid ID and an existing research platform (still being built) which is suddenly useless because of the update. Strange that no one from Oculus has described the fix on this site. Nearly 2 weeks after the first comment. Is this a suitable future development platform? @blackfox.studio @Barbadel @Blitz64 @hawken
  • foohrichfoohrich Posts: 2
    This plugin version is obviously broken. Can someone provide us with an official statement if and when there will be a new release? Is there a short-term solution, for example a guide on how to manually switch back to version 1.38 of the plugin?
  • nix_MWGDnix_MWGD Posts: 1
    Is there a fix for the Oculus Go? My client's project has been broken since this update and no fix I've tried has worked so far, all the suggested fixes seem to be for the Quest.
  • qq443473730qq443473730 Posts: 1
    I Just Buy a New Oculus Quest,I have bought one before,The old one everything is fine except missing localavtar hand,But the New one is recognised as Oculus Go,Only one hand model can be seen and used at the sametime,I doubt if the new Oculus Quest OS can't be  recognised as Oculus Quest by this sdk,the new  Oculus Quest device is downloading the newest by default,I cannot choose the Os Version,I hope this can be fixed in next version. :'(
  • feirtechfeirtech Posts: 1
    edited August 2019
    I'm going to have to add my comments in here as well.   1.39 is broken.  1.38.2 was working fine for us on both Oculus Go and Oculus Quest.  Now 1.39 will not detect the correct headset when I deploy the app from Unity.   It thinks my Quest is a Go.   Very frustrating because I have clients that want their applications finished.   When will this get fixed?!?

    UPDATE: I finally got it working on the Quest by following these instructions.  https://developer.oculus.com/documentation/quest/latest/concepts/book-unity-gsg/#oculus-integration-for-unity

    FYI, last version didn't require you to go through all this just to get it to detect the Quest correctly.   OVRManager is attached to the OVRCameraRig and that's where you need to select the target device.  Don't forget to Remove and regenerate the Android manifest.   What a pain to have to figure this all out when it used to work fine...
  • dlazaresdlazares Posts: 3
Sign In or Register to comment.