hands not showing up with LocalAvator Unity — Oculus

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

hands not showing up with LocalAvator Unity

Blitz64Blitz64 Posts: 8
I'm using LocalAvatar -> AvatarGrabberLeft
Oculus Quest
Unity 2019.1.12f1
Oculus Integration 1.39

I can grab objects but my hands are like invisible.   I'm new to unity Oculus Quest development.   I created a brand new project with just 1 cube so I can grab it.

Initially I can't even grab the objects.  I did Tools -> Remove AndroidManifest.xml and then create Store compatible AndroidManifest.xml.

I tried the AvatarGrab Scene that has built in Oculus cubes and I still can't see my own 2 hands.   I can still grab stuff pretending I have an invisible hand.   Anyone know a fix?


  • AdrellaDevAdrellaDev Posts: 2
    It's a different issue from the Android thing. There seems to be a bug in Oculus Intergration 1.39 that causes the hand mesh to disappear. I reverted back to 1.38 and it was fixed.
  • Blitz64Blitz64 Posts: 8
    Thanks. 1.38 worked and showed my hands.
  • Blitz64Blitz64 Posts: 8
    1.39 works as well.  I need to enter my App ID from dashboard.oculus.com in Oculus -> Avatar
  • GuwopdeLaJeanGuwopdeLaJean Posts: 2
    edited August 3
    Blitz64 said:
    1.39 works as well.  I need to enter my App ID from dashboard.oculus.com in Oculus -> Avatar
    This worked for me!  Thanks I have been going crazy trying to find a fix. Care to explain how you figured it out?
  • alessio.grancinialessio.grancini Posts: 2
    edited August 12
    Hello everyone, after three days working on this I thought to share the sample scene working correctly here. 
    What a pain. Insert your app ID and should be working smoothly. 
    [In both Platform settings and Avatar settings]

    Cheers ! 
  • PFH-GoettingenPFH-Goettingen Posts: 2
    hey there, after adding the app ID to Avatar and Platfrom settings there are still no hands showing up. Any idea what to do now?
  • yarwadyarwad Posts: 5
    In the developer documentation it looked like you don’t have to enter an appID unless you want to use a custom avatar.  Anyone know if this is true?  It would suck if you have to request a new appID every time you wanted to experiment with Oculus in Unity
Sign In or Register to comment.