OVRPlayerControler not working — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

OVRPlayerControler not working

Studio_Ile_PariseauStudio_Ile_Pariseau Posts: 19
edited August 12 in Unity Development
I'm trying to get the OVRPlayerController (from the Oculus Integration package on the Unity Asset Store) to work.

I'm building for Quest and I'm using Unity2019.2.0f1 with Oculus Integration v1.39 to build my APK's

I'm able to build and run the APK, but when I push the left hand joystick forward the avatar jumps ahead a bit then stops.The same happens with the right hand joystick. I have to keep repeatedly pushing the joystick to move forward. I have played with the OVRPlayerController settings with no luck.

What am I missing here?

How do I get the controller to move the avatar smoothly with out stopping?


  • Studio_Ile_PariseauStudio_Ile_Pariseau Posts: 19
    Many thanks to Brian at Oculus for helping with this solution. This is how we fixed it:

    First add a "Character Camera Constraint" to the OVRPlayerController Prefab (see image below).

    Next delete the AndroidManifest file, then build a new one:
    Oculus -> Tools -> Remove AndroidManifest.xml.
    Oculus -> Tools -> Generate store-compatible AndroidManifest.xml.

    And that's it. This worked like a champ for me. Hope this helps. :) 

  • dr3ddr3d Posts: 8
    edited August 14
    Wow Thanks ! I hope this really works - off to try

    Ugh - no such luck. the PlayerController in the Locomotion scene already has the Camera Constraint component. And still controllers are fubar. :(
  • Studio_Ile_PariseauStudio_Ile_Pariseau Posts: 19
    I have not been able to get the Locomotion Scene to work either. The solution above is for the OVRPlayerController Prefab. Best of luck.
  • CorysiaCorysia Posts: 66
    Hiro Protagonist
    I had to downgrade to 1.38 to get my movement working again.  https://developer.oculus.com/downloads/package/unity-integration-archive/
  • Studio_Ile_PariseauStudio_Ile_Pariseau Posts: 19
    The new Oculus Integration package (1.40) is out and fixes a bunch of these issues
Sign In or Register to comment.