Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

How to do permanently turn off the guardian system in Oculus Rift S

Hi
  There has been a problem that guardian would not permanently turn off the guardian(disable boundary) system in Oculus Rift S. I have been trying to turn off the guardian system in all the time,but guardian will be active again although in the settings its still set at disabled. So I had to reset the protection system  and disable it again. Recently I have found many reasons for his appearance, because we really want to find a solution .For example:
  1)Change the intensity of the light.
  2)Change your surroundings (more people is possible).
  3)Restart the pc,and so on.
  There are too many uncontrollable factors, I want to achieve a fully automatic system, instead of manually setting it up again and again.
  Because there are security protections in reality, I am not worried about the harm caused by shutting down the protection system. I believe we have done a good job.However, the guardian system is leading to this trouble, which we constantly check whether the protection system is active.Of course ,it is unnecessary labor.
  I have contacted oculus, but there is still no solution.
Tagged:

Answers

  • jjobietajjobieta Posts: 2
    NerveGear
    edited September 2019
    We have the same problem. We developed three years ago a virtual visit to a cave with rockpaints, and we are using it in a musseum. It was created to be used with oculus rift but with so many visitors we had to buy new glasess as headphones broke. We can´t buy the in-ear headphones because they are not hygienic. 
    The visit was programmed with unity and we used a -nomov tag in the shortcut to disable the need of sensors. We had to leave a sensor connected to the PC but both of them can be hidden. We never had a problem with guardian as we disabled it.

    As now we can´t buy new headphones, we ´ve bought a new Rift-S. The glasses are in a small zone of the musseum,with low lightand  hanging from the floor with a steel cable. Below them is a big place where people can sit if they feel sick or uncomfortable. I use the same application, with the latestet oculus software.

    Now everytime i start the computer, guardian pops up and i have to tell it to dismiss. But my main problem is that if someone finishes the visit or leaves the glasses hanging again, guardian pops up again. I need desperately to disable completely guardian. I don´t need any sensor, or joystick. I only use the gyroscope to move the head in the visit.

    Sorry for my bad english. It´s not as accurately as i´d like it to be.
  • NoWellDoMoreNoWellDoMore Posts: 2
    NerveGear
    jjobieta said:
    We have the same problem. We developed three years ago a virtual visit to a cave with rockpaints, and we are using it in a musseum. It was created to be used with oculus rift but with so many visitors we had to buy new glasess as headphones broke. We can´t buy the in-ear headphones because they are not hygienic. 
    The visit was programmed with unity and we used a -nomov tag in the shortcut to disable the need of sensors. We had to leave a sensor connected to the PC but both of them can be hidden. We never had a problem with guardian as we disabled it.

    As now we can´t buy new headphones, we ´ve bought a new Rift-S. The glasses are in a small zone of the musseum,with low lightand  hanging from the floor with a steel cable. Below them is a big place where people can sit if they feel sick or uncomfortable. I use the same application, with the latestet oculus software.

    Now everytime i start the computer, guardian pops up and i have to tell it to dismiss. But my main problem is that if someone finishes the visit or leaves the glasses hanging again, guardian pops up again. I need desperately to disable completely guardian. I don´t need any sensor, or joystick. I only use the gyroscope to move the head in the visit.

    Sorry for my bad english. It´s not as accurately as i´d like it to be.
    Yes.We are meeting this problem.
    If you are not demanding performance, you can try to use go and quest. When communicating with oculus, they tell us that the enterprise software platform launches in the next month and the first 12 months comes free with GO and Quest enterprise devices bought now. If you are not demanding performance, you can try to communicate with oculus. Of course, we don't know that go and quest have the same problem, because we only want to use rift s ,but the enterprise software platform does not support rift s, it is only for mobile devices.
  • jjobietajjobieta Posts: 2
    NerveGear
    I did not check the Quest or Go as we need a lot of performance to visit the photorealistic cave (it´s based on photogrametry and uses lot of high resolution textures and several million polygons)

    I only want to disable the Guardian as i did in the previous rift. I´ve been forced to buy rift S glasses as i can´t buy rift headphones.
  • FeikovDijkFeikovDijk Posts: 1
    NerveGear
    Any updates? I need this feature badly.
  • chrispi_chrispi_ Posts: 4
    NerveGear
    edited January 9
    Hi there,
    i am not sure whether this is guardian related:
    we also have a setup, where we use the oculus rift s as a plain binocular display without any tracking. Because the oculus rift s installed in a fixed casing, all the sensors are covered. This caused some warnings like "Your device can't track the movement of your headset" or a message that the room is too dark. Any idea to avoid at least popping up those messages?
    Thank you in advance,
    chrispi_
  • TynMahnTynMahn Posts: 1
    NerveGear
    Facebook REALLY needs to fix this.  I do NOT want guardian EVER.  I sit at my desk and fly!!! I don't ever want to touch the stupid gimmicky controller.  I have no use for the stupid thing.  But, now, quite a bit, the stupid thing pops up that I need to set up guardian....it is so frustrating.

    Hey FACEBOOK!!! I want to be able to use my keyboard and mouse in your stupid interface and I want to be able to disable guardian oh and
    I wan to be able to disable that stupid "no audio in your headset" notification....yeah, there is no audio.  I'm using decent headphones not the crap you chose to put in your headset.

    Anyway.....please let us disable guardian.
  • toot.johnson.1614toot.johnson.1614 Posts: 1
    NerveGear
    K
  • Woody3DWoody3D Posts: 60
    Hiro Protagonist
    May 15th.  Still can't turn guardian off. 
  • BillyBobBeavisBillyBobBeavis Posts: 2
    NerveGear
    edited August 26
    Yea, total bullshit. I feel like I don't own my Oculus Rift S, like I only purchased the right to use the hardware with fascist software. Give us control over what we bought from you please. 
  • EledwinEledwin Posts: 2
    NerveGear
    +1, I need this feature too. I don't need guardian as I'm developing a seated experience. 
  • PirateMonkey1978PirateMonkey1978 Posts: 1
    NerveGear
    I join this discussion. I just buyed Rift S a couple of days ago. I put my Rift into box, happy I was going to a better visor, removing 2 USB cables around for sensors. Then, I passed last 2 days to understand how to fix Guardian.
    It continually pop up, asking to set itself, sometimes I can't finish to set it, it start again, it isn't possible to do anything, skipping it doesn't disable it, I was able to use the visor in real "apps" only 10 minutes, with hours and hours fighting against that guardian popping up, with "Play Area not Found" and asking to configure it.
    It is clearly bugged.
    I have also old Quest 1, and it looks to have the same system. Quest never lose the setting. In the same room, in the same conditions of light, and also changing light conditions. I tryed with daily natural light, additional lights, turning off some light, I also made more space in room. Quest alsways work with its Guardian implementation. The new Rift S, I buyed two days ago, it doesn't.
    Now I'm searching for a solution to disable that thing, so at least I could use it, seated, for me it could be ok, waiting a future patch, but looks like there isn't a way to stop that things.
    I buyed it to test Unity developing, I'm learning, but It is useless, can't play, cant do anything, can't use it for development.
    Also, there isn't anyway to check if all cameras are working, maybe I got unlucky and I got a broken visor? However I see a lot of post with Guardian problems on Rift S. 
    Now I'm waiting for new processor to build a new computer, to verify if it is the processor, not powerful enought to manage calculations for Guardian?
    I also tryed a repair of software installation, but nothing changed.
    But, If I do "skip" after I set the ground, and it doesn't save it, and after few seconds pop up again, asking to set again with "Play Area not Found", I don't thing it is an Hardware issue. It should be disabled with "skip", and it doesn't. So, it is a clearly bug into Guardia Oculus Sofware for Rift S.




     




Sign In or Register to comment.