Le RIFT S ne fonctionne plus après un démarrage du PC

Badstar25Badstar25 Messages: 18
Brain Burst
Modifié (18 mars) dans Français Général
Erreur USB INCONNU ( échec d'une demande de réinitialisation d'un port code 43)
Bonjour à tous,
Me voilà aussi avec cette fameuse erreur ! Le casque n'est pas bien reconnu après un démarrage du PC par l'application Oculus (rouge avec erreurs différentes) ainsi que l'erreur USB INCONNU ( échec d'une demande de réinitialisation d'un port code 43 ) dans le gestionnaire de périphérique.
Mon premier message à l'assistance : 


Bonjour, J'ai reçu mon Oculus Rift S hier soir, lors de la première installation, il a bloqué sur un problème de capteur. Je l'ai débranché et rebranché et j'ai réussi l'installation. J'ai réussi a jouer avec plusieurs heures. Ce matin, j'allume mon PC et là le casque n'est plus reconnu...
J'ai vu sur le net que c'est un problème plutôt courant ! J'ai passé ma journée de congé a essayé de résoudre le problème plutôt que de m'amuser avec... J'ai fait : confidentialité camera windows, flash bios carte mère, maj tous les pilotes intel, réinstallation totale et réparation du programme Oculus, utilitaire driver Oculus dans programme files,...
Rien ne fonctionne, la led à l'interieur du casque reste orange ! Il doit y avoir un problème entre votre casque et Windows 10 ! Dés que j'arrive a avoir le casque en total vert dans le programme Oculus en le débranchant et le rebranchant, le casque fonctionne mais des que j’éteins mon PC, le problème revient systématiquement !
J'ai fait le fichier log Oculus et pris des photos du problème ci-dessous.
Ma carte mère est une MSI Z390-A PRO avec des ports USB 3.1 GEN 1 et GEN 2, aucuns ne fonctionne correctement, je l'ai ai tous essayé.
Merci d'avance pour votre aide, j'attend votre réponse avec impatience car là je suis vraiment déçu de mon expérience VR pour le moment.

Leur réponse que j'ai appliqué à la lettre : 

Bonjour,

Merci d'avoir contacté le Support Oculus et de votre intérêt envers notre marque.

Nous sommes désolés d’apprendre que votre Rift S ne fonctionne pas comme il faut. Voulez-vous effectuer les tests suivants et revenir vers nous avec le résultat?

  • Débranchez tous les autres périphériques (USB) qui ne sont pas nécessaires et redémarrer votre ordinateur
  • Installer manuellement les drivers OCULUS

Assurez-vous que les paramètres d'alimentation USB dans le Gestionnaire de périphériques Windows ne sont pas activés en procédant comme suit:

- Ouvrez le Gestionnaire de périphériques
- Localisez vos ports USB
- Faites un clic droit et sélectionnez Propriétés
- Accédez à Gestion de l'alimentation
- Assurez-vous que les options pour économiser de l'énergie sont désélectionnées

J'ai essayé ensuite tout ce qui se trouve sur le net et ici dans ce forum.

Voici ensuite leur message : 

Merci de votre retour et tous les détails de vos tests. Je suis positivement surpris par votre enthousiasme et passion pour la VR et c'est ennuyeux de ne pas pouvoir utiliser le casque tout de suite. Je trouve que vous avez effectué toutes les manipulations potentielles pour régler le problème. Malheureusement, à ce point je ne peux que vous proposer un remplacement du matériel chez le revendeur ou chez Oculus.

Bien sûr un remplacement chez Oculus peut prendre 10 à 15 jour ouvrées et c'est pour cette raison que le revendeur est une meilleure solution quand le casque est tout neuf. Je vois sur les forums des propositions trop extrêmes pour manipuler les paramètres de prise en charge de USB (dans le Bios) mais cela ne fait pas partie de nos procédures de dépannage pour ce problème.

Je reste à votre disposition si vous avez d'autres questions

Passez une excellente fin de semaine,
Cordialement

Ferry
Oculus Support

Donc j'ai suivi le conseil et je suis aller chez mon revendeur, voici mon message de ce matin : 

Bonjour Ferry,
Vendredi 13/03, j'ai retourné mon Rift S chez mon revendeur Boulanger.
Par chance, ils avaient 6 Rift S de stock à l’entrepôt. J'ai donc reçu mon nouveau casque hier avec son numéro de série suivant : ************ date de construction 02/2020.
Et bien c'est exactement le même problème avec celui-là ! 
Avant l'installation, j'ai bien sur tout supprimé ce qui était en rapport avec Oculus de mon PC pour faire une clean install.
L'installation s'est bien passée jusqu'au moment où le microprogramme du Rift s'est mis à jour, l'installation s'est faite et hop j'ai eu un message de windows comme quoi le dernier périphérique connecté n'était pas bon, du coup comme le premier, l'installation n'a pas continué car les capteurs n'étaient pas reconnus...
J'annule donc l'installation car j'avais l'erreur Code 43 dans le gestionnaire de périphérique.
Je déconnecte les câbles du Rift, je redémarre, je vérifie qu'il n'y a pas l'erreur 43, je clique sur le programme Oculus. Je connecte ensuite d'abord le câble USB et 5 sec après le displayport, hop le casque est full vert ! Je finis l'installation, je joues un peu, aucun problème, tout fonctionne parfaitement ! Je redémarre donc le PC et hop casque rouge et erreur 43 !!!
Pour moi :
Le Rift S est bon
Mon PC est bon
Ce n'est pas hardware mais bien software !!!
Il y'a un problème au démarrage de windows, le Rift est "jeté" par windows comme mauvais périphérique. Je pense qu'il y'a un problème entre Windows, vos pilotes Oculus, le microprogramme du Rift et le programme Oculus !
J'ai une solution pour l'instant (cela peut vous aider dans le diagnostique) :
J'allume le PC sans que le Rift ne soit connecté dessus, Windows démarre, je clique sur le programme Oculus, je connecte le Rift d'abord par USB ( 5sec) et ensuite le displayport, le casque est directement vert, je peux jouer comme hier soir plusieurs heures sans aucun problème.
Avant d'éteindre mon pc, je déconnecte le casque et le mets dans sa boite. J’éteins ensuite le PC. Le lendemain même chose, je le connecte après le démarrage du PC et de l'application Oculus et pas de soucis !
Mes connaissances informatiques s'arrête ici malheureusement, c'est pour ça que j’espère le maximum d'aide de vos équipes !
C'est un problème de :
-Drivers Oculus et Windows ???
- Un problème d'alimentation au démarrage ???
- Un problème de timing entre windows,vos drivers, le microprogramme et le programme Oculus ??? Je pencherais là dessus en premier car cela ne se déroule peut être pas dans l'ordre voulu.
Je reste disponible pour faire des tests si besoin !

Avez-vous une idée sur la chose ou le même problème ? 


Réponses

  • cigaremoodscigaremoods Messages: 313
    Nexus 6
    Badstar25 a dit :
    Bonjour à tous,
    Me voilà aussi avec cette fameuse erreur ! Le casque n'est pas bien reconnu après un démarrage du PC par l'application Oculus (rouge avec erreurs différentes) ainsi que l'erreur USB INCONNU ( échec d'une demande de réinitialisation d'un port code 43 ) dans le gestionnaire de périphérique.
    Mon premier message à l'assistance : 


    Bonjour, J'ai reçu mon Oculus Rift S hier soir, lors de la première installation, il a bloqué sur un problème de capteur. Je l'ai débranché et rebranché et j'ai réussi l'installation. J'ai réussi a jouer avec plusieurs heures. Ce matin, j'allume mon PC et là le casque n'est plus reconnu...
    J'ai vu sur le net que c'est un problème plutôt courant ! J'ai passé ma journée de congé a essayé de résoudre le problème plutôt que de m'amuser avec... J'ai fait : confidentialité camera windows, flash bios carte mère, maj tous les pilotes intel, réinstallation totale et réparation du programme Oculus, utilitaire driver Oculus dans programme files,...
    Rien ne fonctionne, la led à l'interieur du casque reste orange ! Il doit y avoir un problème entre votre casque et Windows 10 ! Dés que j'arrive a avoir le casque en total vert dans le programme Oculus en le débranchant et le rebranchant, le casque fonctionne mais des que j’éteins mon PC, le problème revient systématiquement !
    J'ai fait le fichier log Oculus et pris des photos du problème ci-dessous.
    Ma carte mère est une MSI Z390-A PRO avec des ports USB 3.1 GEN 1 et GEN 2, aucuns ne fonctionne correctement, je l'ai ai tous essayé.
    Merci d'avance pour votre aide, j'attend votre réponse avec impatience car là je suis vraiment déçu de mon expérience VR pour le moment.

    Leur réponse que j'ai appliqué à la lettre : 

    Bonjour,

    Merci d'avoir contacté le Support Oculus et de votre intérêt envers notre marque.

    Nous sommes désolés d’apprendre que votre Rift S ne fonctionne pas comme il faut. Voulez-vous effectuer les tests suivants et revenir vers nous avec le résultat?

    • Débranchez tous les autres périphériques (USB) qui ne sont pas nécessaires et redémarrer votre ordinateur
    • Installer manuellement les drivers OCULUS

    Assurez-vous que les paramètres d'alimentation USB dans le Gestionnaire de périphériques Windows ne sont pas activés en procédant comme suit:

    - Ouvrez le Gestionnaire de périphériques
    - Localisez vos ports USB
    - Faites un clic droit et sélectionnez Propriétés
    - Accédez à Gestion de l'alimentation
    - Assurez-vous que les options pour économiser de l'énergie sont désélectionnées

    J'ai essayé ensuite tout ce qui se trouve sur le net et ici dans ce forum.

    Voici ensuite leur message : 

    Merci de votre retour et tous les détails de vos tests. Je suis positivement surpris par votre enthousiasme et passion pour la VR et c'est ennuyeux de ne pas pouvoir utiliser le casque tout de suite. Je trouve que vous avez effectué toutes les manipulations potentielles pour régler le problème. Malheureusement, à ce point je ne peux que vous proposer un remplacement du matériel chez le revendeur ou chez Oculus.

    Bien sûr un remplacement chez Oculus peut prendre 10 à 15 jour ouvrées et c'est pour cette raison que le revendeur est une meilleure solution quand le casque est tout neuf. Je vois sur les forums des propositions trop extrêmes pour manipuler les paramètres de prise en charge de USB (dans le Bios) mais cela ne fait pas partie de nos procédures de dépannage pour ce problème.

    Je reste à votre disposition si vous avez d'autres questions

    Passez une excellente fin de semaine,
    Cordialement

    Ferry
    Oculus Support

    Donc j'ai suivi le conseil et je suis aller chez mon revendeur, voici mon message de ce matin : 

    Bonjour Ferry,
    Vendredi 13/03, j'ai retourné mon Rift S chez mon revendeur Boulanger.
    Par chance, ils avaient 6 Rift S de stock à l’entrepôt. J'ai donc reçu mon nouveau casque hier avec son numéro de série suivant : ************ date de construction 02/2020.
    Et bien c'est exactement le même problème avec celui-là ! 
    Avant l'installation, j'ai bien sur tout supprimé ce qui était en rapport avec Oculus de mon PC pour faire une clean install.
    L'installation s'est bien passée jusqu'au moment où le microprogramme du Rift s'est mis à jour, l'installation s'est faite et hop j'ai eu un message de windows comme quoi le dernier périphérique connecté n'était pas bon, du coup comme le premier, l'installation n'a pas continué car les capteurs n'étaient pas reconnus...
    J'annule donc l'installation car j'avais l'erreur Code 43 dans le gestionnaire de périphérique.
    Je déconnecte les câbles du Rift, je redémarre, je vérifie qu'il n'y a pas l'erreur 43, je clique sur le programme Oculus. Je connecte ensuite d'abord le câble USB et 5 sec après le displayport, hop le casque est full vert ! Je finis l'installation, je joues un peu, aucun problème, tout fonctionne parfaitement ! Je redémarre donc le PC et hop casque rouge et erreur 43 !!!
    Pour moi :
    Le Rift S est bon
    Mon PC est bon
    Ce n'est pas hardware mais bien software !!!
    Il y'a un problème au démarrage de windows, le Rift est "jeté" par windows comme mauvais périphérique. Je pense qu'il y'a un problème entre Windows, vos pilotes Oculus, le microprogramme du Rift et le programme Oculus !
    J'ai une solution pour l'instant (cela peut vous aider dans le diagnostique) :
    J'allume le PC sans que le Rift ne soit connecté dessus, Windows démarre, je clique sur le programme Oculus, je connecte le Rift d'abord par USB ( 5sec) et ensuite le displayport, le casque est directement vert, je peux jouer comme hier soir plusieurs heures sans aucun problème.
    Avant d'éteindre mon pc, je déconnecte le casque et le mets dans sa boite. J’éteins ensuite le PC. Le lendemain même chose, je le connecte après le démarrage du PC et de l'application Oculus et pas de soucis !
    Mes connaissances informatiques s'arrête ici malheureusement, c'est pour ça que j’espère le maximum d'aide de vos équipes !
    C'est un problème de :
    -Drivers Oculus et Windows ???
    - Un problème d'alimentation au démarrage ???
    - Un problème de timing entre windows,vos drivers, le microprogramme et le programme Oculus ??? Je pencherais là dessus en premier car cela ne se déroule peut être pas dans l'ordre voulu.
    Je reste disponible pour faire des tests si besoin !

    Avez-vous une idée sur la chose ou le même problème ? 



    Bonjour,

    Si vous avez une erreur code 43 ce n'est pas la carte mère qui est en cause, mais plutôt  la carte graphique. Vous ne le précisez pas dans votre message, mais si il s'agit d'un code 43 cela signifie que vous avez une carte Nvidia.

    Quel est le modèle? s'il s'agit d'une carte assez puissante avec le casque en plus, avez-vous contrôlé que votre alimentation est assez puissante pour fournir en énergie tout le matériel?

    Avez-vous pensez à regarder dans le panneau de configuration, gestionnaire de périphérique, l'état de vos périphériques. Avez-vous des icones en forme de  triangle jaune -> indicateur de problème.

    Toujours sur le gestionnaire de périphériques, carte graphique, clique droit/propriétés pour voir le premier onglet /général si il est indiqué une erreur dans la zone commentaire. Dans ce cas vous pourriez effectuer plusieurs opérations : soit tenter de mettre à jour le pilote. Désintaller/installer le pilote.



    Si il s'agit bien d'une Nvidia, vous pouvez aussi tenter de passer par l'interface de "gerforce exprience" logiciel Nvidia pour installer les pilotes.

    Il faut aussi envisager que la carte elle-même à un problème hardware.

    Autre question, vous n'avez pas overclocker votre carte mère, parfois cela pose des problèmes avec Oculus.
    Cette carte à aussi un displayport, vous êtes bien connecté sur le displayport de la CG et pas sur celui de la CM?

    Enfin voilà quelsques premières pistes qui me viennent à l'esprit.

    Cordialement

    MSI Z390 Gaming Pro Carbon AC, Intel core I9-9900K, MSI RTX 2080 TI Gaming X Trio 11go, Corsair DDR4 16go, SSD Samsung NVMe M.2 500go, SSD Samsung 2To 860 QVO,
  • Badstar25Badstar25 Messages: 18
    Brain Burst
    Modifié (16 mars)
    Bonjour Cigaremoods, merci de vous intéresser à mon problème.
    Le code 43 est bien dans la partie USB du gestionnaire de périphérique, vous êtes le premier a me dire que cela vient de ma carte graphique mais effectivement vous avez raison c'est une Nvidia.
    Du coup je n'ai pas vérifié la partie de la carte graphique dans le panneau, ici je suis au boulot.
    Ma carte graphique est une MSI Ventus RTX 2060 6G.
    Mon alimentation est une Corsair 550W, j'y ai pensé mais je fais aussi de Simracing sur triple screen et jamais eu de soucis de performance ou le pc qui s'arrete car pas assez de courant.
    Pas d'overclock du PC de ma part mais la carte graphique est peut-être une version OC, il faut que je vérifie ce soir.
    Le problème ne se pose que lors du démarrage casque déjà connecté avant celui-ci.
    Quand je connecte le caque par la suite, je peux l'utiliser sans problème.
    Petite info aussi, mon écran principal est un asus 144hz avec g-sync COMPATIBLE le VG278Q, il est bien paramétré dans Windows en 144hz et G-sync est activé. Cela ne peut pas poser le problème ? 
    Mon casque est bien sur un DP de la carte graphique ;-)
    L'USB est sur la carte mère dans le port le plus puissant SS10 normal pas type-c.
    Je déplace ma tour du bureau gaming en bas à mon simulateur triple screen en haut de temps en temps.





     
  • Badstar25Badstar25 Messages: 18
    Brain Burst
    J'ai fait le calcul de puissance sur le site MSI et je tombe à 420W maxi donc 550W cela devrait être bon. On ne sait pas mettre casque VR dans le calcul, il prend combien le casque ? Je vois que sur le site materiel.net les tours qui ont du matériels équivalents ont une alimentation de 550W. 
  • Badstar25Badstar25 Messages: 18
    Brain Burst
    Je vais vérifier la carte graphique ce soir et je vais complètement la réinstaller, je vous tiens au courant.
    Encore Merci ! 
  • Badstar25Badstar25 Messages: 18
    Brain Burst
    Voilà j'ai supprimer mes drivers nvidia avec DDU en mode sans échec, windows s'amuse a réinstaller la carte seul, ce qui est vraiment ennuyant ! Je ne veux pas des drivers USB type-C et Audio HD ( le son passe par les ports de la carte).
    J'ai beau désactiver l'installation automatique, il le fait systématiquement...
    Je n'ai aucun problème dans les remarques de la carte graphique par contre.
    Comme beaucoup le pense, cela vient d'une incompatible entre les programmes et drivers OCULUS et Windows 10.
    On est encore loin du casque plug and play ! 
    Je vais continuer a le brancher après démarrage en espérant un miracle venant de chez Oculus...
    Ils n'ont toujours pas répondu a mon message au passage...


  • cigaremoodscigaremoods Messages: 313
    Nexus 6
    Modifié (17 mars)

    Badstar25 a dit :
    Voilà j'ai supprimer mes drivers nvidia avec DDU en mode sans échec, windows s'amuse a réinstaller la carte seul, ce qui est vraiment ennuyant ! Je ne veux pas des drivers USB type-C et Audio HD ( le son passe par les ports de la carte).
    J'ai beau désactiver l'installation automatique, il le fait systématiquement...
    Je n'ai aucun problème dans les remarques de la carte graphique par contre.
    Comme beaucoup le pense, cela vient d'une incompatible entre les programmes et drivers OCULUS et Windows 10.
    On est encore loin du casque plug and play ! 
    Je vais continuer a le brancher après démarrage en espérant un miracle venant de chez Oculus...
    Ils n'ont toujours pas répondu a mon message au passage...



    Bonjour,

    Exact, pour la carte malgré plusieurs correctifs de la part de Nvidia, il existe bien certains problèmes entre la config de la carte et windows 10, bien évidement en fonction des milliers d'instructions qui circulent dans votre système cela rend la tâche très complexe. Parfois cela passe parfois non. Mais ce n'est peut être pas elle!

    Pour répondre à une de vos interrogations Le rift s consomme Max 4,5 w.
    Débrancher/brancher plusieurs fois provoquent une usure accélérée du métal/contact des prises.

    Une démarche dichotomique devient nécessaire pour isoler l'élément qui provoque votre erreur/défaut.

    Nous serions dans une période un peu moins trouble (confinement oblige) je vous conseillerai de faire tester votre carte dans un bon magasin informatique pour lever le doute, écarterai éventuellement la carte de la chaine d'erreur.

    Si vous avez un deuxième ordinateur à disposition vous pourriez brancher votre casque sur celui-ci pour constater si le phénomème se reproduit. Vous pouvez tout à fait utiliser un autre ordinateur, du moment que vous utilisez le même compte Oculus. Vos jeux peuvent être installer aussi sur ce deuxième ordinateur sans payer à nouveau ceux-ci. Seule condition : utiliser un seul ordinateur à la fois pas les 2.
    cela écarterai à coup sur le casque de la chaine d'erreur.

    et ainsi de suite.

    Cordialement.



    MSI Z390 Gaming Pro Carbon AC, Intel core I9-9900K, MSI RTX 2080 TI Gaming X Trio 11go, Corsair DDR4 16go, SSD Samsung NVMe M.2 500go, SSD Samsung 2To 860 QVO,
  • Badstar25Badstar25 Messages: 18
    Brain Burst
    Réponse du support : 
    "Pour ce genre de problème, il s'agit d'une chose connue pour le moment auprès d'Oculus.

    Je vous invite donc, pour la bonne utilisation de votre Rift S, à bien débrancher votre casque lorsque vous couperez le PC. Branchez le casque après que le PC ait été allumé, une fois sur votre session Windows.

    Pour vous expliquer la situation, lorsque vous allumez votre ordinateur, le PC vérifie le bon fonctionnement de tous vos ports (USB et Display Port). Le casque Oculus nécessite d'avoir l'énergie du port USB avant le Display Port pour qu'il soit bien détecté et fonctionne correctement. Dans votre situation, à l'allumage, votre PC doit vérifier le Display Port avant les USB, ce qui entraîne ce problème.

    Nos ingénieurs et développeurs travaillent à ce sujet afin de ne plus tenir compte de l'ordre de branchement du casque ou même de ce problème à chaque allumage de votre PC (pour ne plus avoir besoin de débrancher votre casque après chaque utilisation)."

    "Notre équipe recherche toujours l'origine et la cause, car comme vous avez pu le voir mes explications ne sont pas précises à 100%. La description n'est que succinct et basique.

    Lorsque notre équipe aura plus d'éléments, une communication ou un article support en question sera certainement créé. Vous pouvez simplement retenir que pour plus de sûreté et pour une meilleure durée de vie du casque et éviter son usure (au niveau des câbles par exemple), débranchez-le après chaque utilisation et rebranchez le une fois sur votre session Windows.

    Nous comprenons que celui puisse être exhaustif par moment (se baisser, pour brancher parfois les câbles derrière la tour d'ordinateur) et pour cela nous ferons au mieux pour régler le problème. Je n'ai pas encore de date sur la sortie de ce fix."

    Donc on attend la MAJ avec impatience ! 

  • Badstar25Badstar25 Messages: 18
    Brain Burst
    Si vous avez le même problème que le mien, merci de quand même créer un ticket sur le support Oculus ! 
    Au plus des utilisateurs remontent ce problème, au plus vite Oculus règlera celui-ci ! Merci. 
  • Dom-60Dom-60 Messages: 10
    Brain Burst
    Bonjour.
    Le support Oculus m'a répondu en m'indiquant quelques conseils dont celui de sactiver mon antivirus
    et Ho miracle !!! mon rift s refonctionne correctement.
    Si ça peut aider des personnes n'hésitez pas à partager ceci.

     Bonne soirée,cordialement.




Connectez-vous ou Inscrivez-vous pour répondre.