cancel
Showing results for 
Search instead for 
Did you mean: 

Quest PTC v44 Release Megathread

Oculus_RyanS
Community Manager
Community Manager

The Public Test Channel (PTC) for Quest and Quest 2 v44 is starting to roll out. Let's use this thread for collecting feedback on it. Share your impressions and let us know if you see any issues. Please make sure to also send in bug reports along with posting here if you notice anything going wrong.

 

Thanks to everyone testing out PTC and sharing your feedback! We appreciate your help testing out the core functionality of software as we develop!

Help others find great discussions and answers by adding kudos and marking solutions to your questions.
28 REPLIES 28


@AzeezAncelo wrote:

I have a reason to believe that you guys screwed up Cable Link with 42+. The last time I used cable link I was on 41 and everything worked fine. Despite numerous driver updates, repairing the PC app, reinstalling the PC app etc. Cable Link does not work. AirLink still works though, so I don't think it's an Nvidia problem.

Tried multiple cables, they all transfer data through adb etc but they don't start the Link dash, I think Oculus software thinks I still enabled AirLink and refuses to launch dash over Cable.

 


Is this with PTC v44?  I'm not on the Quest PTC program and I've not had any problems with my Q2/rtx3090 with Link or Air Link using the current v43. 

 

I'm really not sure why this is all a little hit and miss for some?  All I can suggest is that you work with Oculus support to try to resolve your issues.  Good luck mate and cheers.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

UltraCyberGod
Level 2

I just got v44 now when I put the headset on it does not automatically know, I have to click the power button... Hopefully this isn't an advancement..

Oh oh oh I actually have a helpful tip for once! If you are one of the people (like me) who had to unplug their quest link cable every oculus pc software reboot and occasionally when link crashed? 
I discovered that toggling AirLink on and off then waiting a few seconds resets the connection. Saves our usb ports some wear and tear. And the toggle is right there in the same link window. 

tanubon
Level 7

v44 was already released. But no official post, RyanS?

 

And still nobody got app filiter of v41. WTF.

I have a recently replaced Quest 2 which my iPhone app can't see and it can't see my controllers (original controllers from 2020).

 

Will sideloading v44 help me ? Where can I get it ?

 

Is there a test version of the iPhone app I can try ?

 

I have tried every possible forum suggestion and I have a support ticket open for last few weeks waiting for a fix.

 

Quest 2 is stuck on pair the controllers screen, which I guess are still paired to my old Quest 2, which I was asked to return.

 

Need help ?

I have a similar problem,

my quest 2 is stuck in the initial setup at the controller pairing screen,

I tried my controllers with another quest 2  both pair without issues.

meta support told me they will replace my quest 2, which was 16 days ago,

they are still telling me they are having some logistic problems :(.

 

It would be nice to get the v44 update, 

at least I would like to try to "repair" my device by updating it

Oculus_RyanS
Community Manager
Community Manager

Hey @doctor.oculus.2019 and @Philsko , there's an issue that the team is working on right now with some replacement headsets not being able to pair with controllers due to a version issue. They're trying to get a fix in place since there's no official place to download the v43/v44 software in order to side load it on your device. There are some community members that have had success using a version of the software provided by the community, but it's not something we'd officially recommend. There are some threads on the forums about this issue which we'll update as soon as the engineering team's given us more details in regards to a proper fix. Sorry for the trouble, and thanks for your patience! I know it's rough having to wait to jump back in.

Help others find great discussions and answers by adding kudos and marking solutions to your questions.

Hi, thanks for the information.

 

I remembered yesterday what actually happened with my original 2 year old headset before I was asked to return it a few weeks back.

All was good, for some months before any problems where it had updated and booted with the Meta logo (don’t know what version that was introduced with). 

I hadn’t got round to creating a Meta account. Then one day the headset said I needed to connect the device to a Meta account to continue. So I migrated my Oculus account to Meta. Next the headset wanted me to enter a code to proceed? But I couldn’t because the controllers no longer worked! 

The only thing I find online was the factory reset process and after that I couldn’t link the headset with my phone anymore and controllers still didn’t work.

That’s when I went to support and received a replacement which didn’t resolve the issue.

 

So I think my original headset was on V43 but could not talk to my controllers which had been updating from time to time.

 

I have updated the replacement headset to v43 myself which hasn’t got me any further. The unit connects in the iOS Bluetooth list but the oculus app fails to pair. Although it’s difficult to prove the update was successful (it did do the ‘down arrow’ updating icon).

 

I have been giving a procedure by support to try the Windows app to pair the device with my account.

 


I’ve not seen the Windows app mentioned anywhere online, I’ll try that next.

 

Many thanks