cancel
Showing results for 
Search instead for 
Did you mean: 

can not use VRTK

13648877531
Level 2
Exception: An SDK Setup from the provided list could be loaded, but the device is not in working order. There are no other Setups in the provided list to try.
VRTK.VRTK_Logger.Log (VRTK.VRTK_Logger+LogLevels level, System.String message, System.Boolean forcePause) (at Assets/VRTK/Source/Scripts/Internal/VRTK_Logger.cs:174)
VRTK.VRTK_Logger.Error (System.String message, System.Boolean forcePause) (at Assets/VRTK/Source/Scripts/Internal/VRTK_Logger.cs:130)
VRTK.VRTK_SDKManager+<FinishSDKSetupLoading>d__96.MoveNext () (at Assets/VRTK/Source/Scripts/Utilities/SDK/VRTK_SDKManager.cs:943)
UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at C:/buildslave/unity/build/Runtime/Export/Coroutines.cs:17)
43bo9s6ac38o.png
When I check virtual reality support box,and choose  oculus,it will work like the first picture,and then,it like the second picture:
c4bh6zxhpykg.png
I don‘t konw why,oculus just can't be choosen.
4 REPLIES 4

Geist2501
Level 3
Since you did not say anything about whether or not you have installed the Oculus Integration from the asset store and SDK packages in the Package Manager, i would ask you to make sure you have done so.

edit: Also make sure you run one of the recommended versions of unity. Check the FAQ. And unless you definitely need features from unity 2019, consider using a earlier version that does not force gradle building. You can always port up later, but gradle takes ages to build each time you want to test something.

13648877531
Level 2
输入你的评论Geist2501 said:


Since you did not say anything about whether or not you have installed the Oculus Integration from the asset store and SDK packages in the Package Manager, i would ask you to make sure you have done so.

edit: Also make sure you run one of the recommended versions of unity. Check the FAQ. And unless you definitely need features from unity 2019, consider using a earlier version that does not force gradle building. You can always port up later, but gradle takes ages to build each time you want to test something.


My unity vesion is Unity 2018.3.14,and I have done what you said ,but it doesn't seem to work.And the
 problem  just like what I say before.


Kathi_dev
Level 2
I don't know if that might still help, but in case someone else stumbles across this problem:
- Make sure you've switched your development platform to Android (you can do that in your build settings)
- Also make sure you've set up everything correctly, like e.g. the API level to KitKat and so on 
- Finally, you need to go to the VRTK SDK Manager Prefab in your scene and choose "GearVR (Android: Oculus)" from the Quick Select Dropdown-Menu. 

After that, you should be able to add Oculus to your Oculus VR SDKs in your project settings.

coernel360
Level 2
Also helps to uncheck "Auto Manage VR Settings" on your VRTK SDK Manager, under "Setups" .