cancel
Showing results for 
Search instead for 
Did you mean: 

No sound when using Oculus Spatializer between FMOD2.1.7/Unreal4.25.4 on Win10

I'm not getting Oculus spatialiser linking between FMOD and UE4 on Win10.
I have regular (non-Oculus) 3D sound working fine through Rift S.

 

As instructed here https://developer.oculus.com/documentation/unreal/audio-osp-fmod-usage/?locale=en_GB I have my OculusSpatializerFMOD.dll (with text file 'OculusSpatializerFMOD') sat next to my fmod.dll files in UE4.26 > Engine > Plugins > FMODStudio > Binaries > Win64 but the OculusSpatializerFMOD doesn't appear as per this image:
Image 1.png

 

In UE4 the Oculus-Spatialized event sometimes appears as '3D - False' in details, other times 'True' with 0 min and max, not sure where it's getting 0 from.

Quick video demo'ing my test:
https://youtu.be/jA4bzG1WDXk


Other stuff I've tried:

guide from - https://developer.oculus.com/documentation/unreal/audio-osp-ue

guide from - https://developer.oculus.com/documentation/unity/audio-osp-fmod-overview/?locale=en_GB (no idea where mysterious 'Oculus Spatializer folder > `AudioSDK\Plugins\FMOD\x64` folder is, i assume it's same x64 folder from the download ZIP in '\ovr_audio_spatializer_fmod' folder)

 

in FMOD > Oculus plugin instead of spatializer on each event master track, mono in, stereo out
mixer master bus stereo out (tried both stereo and 5.1 in) and have Oculus Spatial Reverb

 

in UE4 > Platforms > Win > Audio > Spatialization and Reverb Plugin > Oculus Audio, and Plugins > Oculus Audio > enable Late Reverberation, Plugins > FMOD Studio > Output Format Stereo

 

any help much appreciated, thanks.

1 REPLY 1

Apparently I needed to manually enter the plugin name (OculusSpatializerFMOD) into the ‘Plugin Files’ list - I thought it should scan for it it..

 

The Oculus Spatial Reverb is now glitching in UE4 when I have Reflections turned on, which is a legacy problem on your side it seems. I could turn off Reflections but that might defeat the purpose?