Showing results for 
Search instead for 
Did you mean: 

Spatial Audio not working - Oculus Go / Gear + Unity 2017.4.2

Level 4
Hi there, I'm currently working on an app which should support spatial audio. In my last apps for Gear VR, audio wasn't that important.
I started with an empty project and it has just basic scene / 2 scripts / 1 objects. Simple. Under Edit / Project Settings / Audio I choose OculusSpatializer as Plugin and Decoder. In Editmode everything works fine (tested with a 360 Video with ambisonic audio track), but on the Oculus Go it has no effect. I also noted, that adb gives me this:
05-08 18:43:33.758  8206  8221 I Unity   : SystemInfo CPU = ARMv7 VFPv3 NEON, Cores = 4, Memory = 2771mb
05-08 18:43:33.758 8206 8221 I Unity : SystemInfo ARM big.LITTLE configuration: 4 big (mask: 15), 0 little (mask: 0)
05-08 18:43:33.758 8206 8221 I Unity : ApplicationInfo com.blendfx.hsmw360 version 0.18 build 448b0855-1035-4981-abec-b3e0d10cae64
05-08 18:43:33.758 8206 8221 I Unity : Built from '2017.4/release' branch, Version '2017.4.2f2 (52d9cb89b362)', Build type 'Release', Scripting Backend 'mono'
05-08 18:43:33.825 8206 8221 E Unity : Unable to find libAudioPluginOculusSpatializer
05-08 18:43:33.856 8206 8221 D Unity : GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_sync GL_OES_vertex_half_float GL_OES_framebuffer_object
I think "Unable to find libAudioPluginOculusSpatializer" is the problem, but I found no useful information in world wide web to solve my problem. My test was in Unity 2017.3 - then I updated, I imported the OculusAudioSDK (shouldn't be necessary) and tried some other things, but nothing helped.

Hope, someone has an idea...?

Tested on GearVR (s7) and Oculus Go (installed via Oculus Platform as Alpha Channel App)
Unity 2017.4.2

best regards

Level 4
Meanwhile I tested a ambisonic wav file in my project and this seem to be played back correct. It could be, that this mentioned adb error is just irritating.

Meanwhile I asume, that the the problem is to playback a video with ambisonic audio track. It's interpreted like a normal stereo track - no spatial effect. This could be a problem of unity, that i cannot flag the audiotrack as ambisonic.

In general there are few information about playing a 360 video in unity with spatial audio... maybe you or someone else has some more experience.

Level 4
I also created a post in the unity forum with some more infos about 360° + spatial audio. Link

Level 4
In unity forum (see above) AndrewRH from renderheads (I use their video plugin, which also uses facebook audio 360 sdk) writes:
The MKV and Opus codec restriction came from FB as this is what they support in their Audio 360 SDK
Maybe your SDK could support also mp4 with spatial audio?

I also recognized, that the fb encoder in experimental matroska settings converts the audiotrack always to 10 channels, but in my case I just need standard first order with 4 tracks. In general I would love to get more options.

Level 4
Another thing: I wanted to download the Oculus Ambisonics Starter Pack 1.0 from the download section. I tried it two times, but at the end I can't open the zip files. It is corrupt.